Can't pair Morph with iOS

I am unsuccessfully attempting to pair my Morph with my iPhone X with iOS 13.3. The light on the Morph is flashing blue and it is not connected to any other devices. I am seeing the following error consistently when trying to pair from iOS:

Any ideas?

Thank you!

Hm, according to this description the Morph cannot be connected to any other device via USB while using the Bluetooth mode. Beside that - no idea. Bluetooth 5 should be downwards compatible to 4.0 LE.

The Morph is picky in that it seems to only pair with a single device at a time, and you have to manually “unpair” with it to pair it again.

I too have been having problems with pairing bluetooth but for me it’s with my android xaiomi note 6 phone. I did get it to work before with the keyboard before I upgraded the firmware but I’m not sure that’s related. I also tried pairing with my Linux Mint that fails also. like you I see the blue light blink slow but I see no devices listed on my bluetooth device I’m trying to pair with. The Linux Mint is version 19.3 Tricia.

I saw another person that had the same problem with apple IOS and he was told to try this to unpair the device: I went ahead and tried that on my android and now at least I get as far as seeing the morph listed on my bluetooth screen. but attempts to connect now seems to fail. But at this point I don’t have the keyboard overlay installed so that could be my new problem. I have a custom linnstrument simulator running on it now that’s not easy to remove so I’ll try it again later when it can be done.

Update after it seemed it would never connect I closed and reopened setup and now I note that the morph is now paired after doing the unpair above, but I don’t see any midi devices listed in my android synth app called DRC. so maybe bluetooth midi is not working yet on this android?

Even I have been facing the same issue. I cannot be pairing morph with my apple device. Whenever I tried, it’s crashed and shows the screen an error message “apple application support was not found” so does anyone knows, how can I resolve this issue. I tried various methods but noone worked.

Hi Jimmy,

This is likely a bluetooth issue. We recommend taking the following steps:

  1. Unplug the Morph USB and remove the previous Morph pairing from any previous devices (the Morph can only be paired with one device).
  2. Press the button on the top left. All of the LEDs should flash and a blue LED should come on after 3 seconds.
  3. After the blue LED is on, press the button twice. All the LEDs will flash and the Blue LED should turn on after 3 seconds again. It will now slowly change between bright blue and a dimmer blue every 3 seconds.
  4. After the blue light is on and changing every 3 seconds, open up the Bluetooth menu.
  5. After you start the blue LED, you will have 1.5 minutes to connect before it stops and the blue led turns off. If you need to try again, just press the button twice to enter pairing mode.
  6. If none of these steps work. Hold down the power button for 8 seconds to do a hard reset and then try steps 1-5 again.

Please let us know if you’re still experiencing issues.


I have the same issue, I can’t pair mine in iOS and pairing with a computer has only worked once and the connection was unstable/slow. I’ve followed all of these instructions, tested on 3 iPads and 3 Macs and updated firmware.

I’ve had exactly the same issue, and it turned out the the Morph was still paired with an old iPad. The only way to use it with the new iPad was to unpair from the old.

This is a pretty serious design flaw. It means if you sell or lose the old device then you can never use your Morph ever again. Please change this!

Twitter RSS Facebook