Innovator Not Responsive With Drum Sticks

I was hoping to use my Morph to replace my Octapad for a my ‘travel to gigs on a motorcycle’ set. To that end I made a 4x2 drum pad configuration, but the innovators overly is not very good with drum sticks. It doesn’t seem fast/sensitive enough to register strikes reliably. I do have the drum overlay but I need 8 pads and there is simply no way I will ever be precise enough to hit the small zone in the dual zone pad with a stick.

I’ve tried two different weight sticks and mallets as well.

I don’t use drum sounds for this, I use the Octapad for melodic things. I do hope there is a way to make it more sensitive as it would really solve some issues for me and was the primary reason I bought the morph.

Is this a latency issue or an issue with rolls and flams? Obviously, if it is a latency issue, that can be somewhat addressed on the software end. However, I’m guessing you’ve played with those things, as you clearly have MIDI drum experience!
The Drum pad overlay does work with a higher speed scanning, so that definitely helps the speed of that overlay. This does bring up a good point for the innovator’s overlay: Because its use is not defined, It would be great to have the option to switch it to the high-speed mode, similar to the drum pad. I’ll put that in the the queue.

Hi, Thanks for the query. The issue is the unit not registering hits reliably. If I hold the stick firmly and not allow it to bounce off the pad as much then the strike registers, but that isn’t a natural way to play nor allows for any sort of speed.

I am too a drummer and want to use the innovators overlay for stick use (also on the Buchla Thunder overlay). The feature of manually turning this on or off would be great.

1 Like
Twitter RSS Facebook