Kenton Midi USB host mkII not recognizing Sensel Morph

#1

I bought the Kenton Midi USB host mkii based on your recommendation. However, I only get the blinking light on the host when I plug in the Sensel Morph. When I plug in my Arturia Keystep, it recognizes it and the light stops blinking (stays solid). What am I missing?

#2

Very odd - we used it successfully for days at Moogfest. I would make sure that your firmware is updated on your Morph to duplicate the conditions on the Morphs we used the Kenton with.

#3

Yes, I bought my Morph from you at Moogfest. That’s why I picked the Kenton to connect to my standalone instruments.

The firmware is up to date (0.19.180). The Morph blinks twice when I plug into the USB port on the Kenton but it doesn’t finish the connection. The indicator light just blinks.

All other controllers connect easily to the Kenton with a solid, not blinking indicator light.

#4

I know this may sound primitive and possibly annoyingly obvious, but … try a different USB cable. If that fails, please contact Kenton and cc peter at sensel.

#5

Always worth a try. Yes, I tried several different cables and all have the same result. The USB cable that came with the Morph connects in a flash to my Keystep. Doesn’t seem to be a cable issue. I’ve requested a return to Kenton, assuming there’s a problem with the USB host.

#6

Ok. Perhaps there is a firmware update on the Kenton device itself? One possibility is that your device has a slight difference in firmware from the one that we have, and therefore doesn’t work.

#7

That’s what Kenton suggested. But a firmware upgrade didn’t work. But if others have this problem, the firmware is available here:
The latest firmware can be downloaded here:
https://www.kentonuk.com/downloads/flashindex.shtml