(Mac) Morph not showing as control surface in Ableton

#1

I just downloaded the Ableton script and tried to set it up according to the instructional video, but the Morph doesn’t show up in on the “control surface” section.

Thanks in advance!

#2

I’m sure that the Sensel techs will jump in.

I had the same problem. They said that the current Albeton Morph scripts use new scripting features in Live and require Live 10.0.4 or higher to work correctly. I upgraded to 10.0.6 and the installation worked and Live was able to see the Morph Control Surface.

Hope this helps.

#3

Same problem here- all Morph firmware and software current. OSX10.12.6
Live 10.0.6

Guys?

#4

I’m not sure why this didn’t work for you but I just confirmed this is all ok:
Go to the Ableton application, right click, and show package contents. Navigate to Contents/App-Resources/MIDI Remote Scripts and delete the Sensel folder. Go to github and download
https://github.com/sensel/sensel-controller-scripts/archive/1.1.zip
navigate to
/Users/nbor/Downloads/sensel-controller-scripts-1.1/Ableton/Installer/Mac/Packages Project/Sensel_Morph/build/Sensel_Morph_LiveScripts.pkg
and run the installer there.

We will soon be updating the scripts on the store.