Morph Thunder not working with Retrokits RK005 usb host

#1

Hi all. I realize that a similar thread about a month ago was flagged as solved, but it was with a different host. I wanted to report that presently the Morph Thunder with Retrokits RK005 usb host is not working, even after the firmware updates:

Sensel Morph Firmware 0.19.180 (per prior advice, set to low power mode and sent to morph)
Retrokits RK005 Firmware 1.8

Retrokits was tested with an OPZ and Keith McMillen QuNexus and worked with both. So the RK005 appears to be functioning properly as a usb host.

But as soon as the Sensel Morph was connected, all lights went off and the Morph ceased responding. Presses to the Morph power button could cause a brief blink, but it would go out again. Lifting up the overlay would cause the LEDs to move, but once in place no LEDs would light when the overlay was played. Thunder was confirmed to be transmitting midi when connected to mac. Morph was set to low power mode, and the RK005 was hooked to a power bank as well as a 2.4A charger, but these power configurations didn’t change anything.

I’m trying to use the morph with the RK005 host as a minimal controller in a dawless setup.

#2

I can confirm that my Morph with Buchla overlay does not work with the Retrokits RK005 either.

#3

Weirdly, the Morph doesn’t work with a powered hub on the RK005, so it doesn’t appear to be a power issue. To be clear, a powered hub on the Rk005 host port AND the Rk005 powered by a 2.5 amp charger.

#4

Hello, thank you for reporting this issue with the RK005. We have ordered one in order to replicate and investigate what could be causing this issue. Our best guess at this time is it does not handle a composite USB device (keyboard+MIDI+mouse+etc) like the Morph. We have used these MIDI hosts in the past without issue but we will continue to look into the RK005.


#5

Per a suggestion from Retrokits, I tried an unpowered hub. It did not work either.

It’s not as if the Morph is transmitting anything in this situation. As soon as it is plugged into the RK005, it blinks and turns off.

#6

Thanks for ordering one up! It would be great if we can get these working since the RK005 has a lot of interesting features. I have tried it with an unpowered hub too… no dice.