[Solved]: How to Turn off Morph's auto-arm of tracks in Live?

Hi there, new user. I’ve set Live 10’s MIDI Control Surfce prefs as advised for the Sensel Morph.
However, now Live auto-arms any selected MIDI track in Session Mode/View, which screws up the functionality of my Live projects. I use multiple controllers in my projects in the studio and on stage.

How do I turn off/disable that auto-arm functionality while still having the Morph as a defined, activated control surface? Mac 10.12.6, Live 10.0.6

Hi there - just want to get a bit more info. Are you looking to be able to click on a MIDI track without it arming to record, or are you looking to click on an instrument/effect without it auto-mapping to the Morph for control?

In order to disable the auto-arm functionality, you’d need to edit the script. Adding this to the end of the Morph.py file will prevent the script from using the auto-arm feature:

def _can_auto_arm_track(self, track):
	return False

You’ll have to save the file and restart Live for it to take effect. I’ll recommend adding a global flag in the Map.py file to make this a little easier in the future for the next version release.

An easier workaround is to manually arm a “dummy track” somewhere in your project…when a track is explicitly armed, the implicit armed state (i.e. auto-arm state) of the track shouldn’t get changed when selecting a new track.

a

2 Likes

@rdorsche Let us know if you need assistance in making that change - if you haven’t done it before, it can be a bit weird.

Thanks, Peter… This isn’t my first rodeo, editing python scripts for Live. I remember trying to fix something for the KMI QuNeo I used to have. I don’t know Python, but I get the gist. Once I make the edit, I’ll make a copy of the file and back it up. Then I have to be mindful of whenever Live have an update and reinstall the modified Sensel script. I’m sticking to Live 10.0.6 fot the time being until 10.1 has a proven track record, or, a right-of-decimal update.

To answer to David:
Looking to prevent the auto-arming.
While I get the using-Live-only-with-a-Morph approach? I will most likely use it in concert with a series of controllers, most notably the Novation LaunchControl XL, which I use to set levels on the fly, and arm tracks on the fly. If the Morph is arming tracks willy-nilly, that disturbs my rig’s flow.

Virus as both 61-key controller AND hardware synth --> MIDI Patchbay
LaunchControl XL and Launchpad sitting on top of the Virus --> USB Hub
Linnstrument --> either USB hub or the MIDI Patchbay, depending on the midi load for the set/softsynths used
and now the Morph with Innovators overlay with custom functionality --> USB Hub
All into Live Suite 10.0.6.

The auto-arming and auto-mapping are both unnecessary for how I work.
I’d rather custom assign everything, so there are no surprises.

Thanks for the extra info. This may not completely solve your problem, but you can turn off exclusive arming in Live’s options menu - such that you can have an unlimited number of tracks armed, rather than one at a time. This way, you won’t lose the arming on other tracks when you move around with the Morph.

I do have Live’s exclusive arming turned off in the prefs already. I just wanted to disable the Morph’s arming of tracks, period, and leave that task to my Novation LCXL.

I did not see your reply here… thanks for doing the footwork for me! trying it out now

Confirmed, @amounra’s solution worked; no more auto-arm when switching or making new channels in Live (10.0.6 as of typing this). Thanks!

1 Like
Twitter RSS Facebook