How to configure MPE pitch bend in Surge synth?

Hi, there’s something I’m not getting when trying to get an MPE grid layout (the 6th tuned LinnStrument Mini by Tj-Shredder) to do pitch bend with the Surge synth.
Even Roger Linn’s presets are not doing any pitch bend.

What are the necessary settings in the SenselApp and in Surge (running in Live)?
I somehow understand the Morph’s pitch bend settings of 920mm in each MPE field. There are 13 fields of 18.5mm width in a row, so sliding across 49.83 (hypothetic) fields would go to the full pitch bend value, isn’t it? And is this bipolar or not, i.e. 920mm to the right for positive max and 920mm to the left for minimum?
But how should this relate to the setting in the softsynth? In the presets the MPE pitch bend range seems to be 48, but there’s no bend happening.

Any hint appreciated, cheers…
…Diemo

When X has Absolute off, it will be a bipolar value. As for Serge not getting any bend in, what is your host for the plugin?

what is your host for the plugin?

Ableton Live 10

If that is the problem, what would be the leanest and most practical VST3 or AU host for an MPE synth on Mac (supposing all I want to do is run one softsynth)?
Thanks!

This could be Live 10 issues since it doesn’t support MPE. I can’t really speak to the leanest, but you probably have Garage Band, and Bitwig 8-Track came with your Morph. MainStage would also work. The AU Lab host is part of the Apple developer tools https://www.soundonsound.com/techniques/free-audio-units-host-app
Live 11 Beta also works!

Hi Peter, thanks for the host tips, will check them out.
Meanwhile I hosted the Surge synth in Max’s vst~, and there bend works, but neither pressure nor y tilt, LOL.
That must be due to my fledgling MPE knowledge, as all data is received by Max.
I hadn’t gotten the MIDI routed at all in AULab, should try again and look for an update, mine’s from 2012…
Cheers

Max is a good option, too.
You need to use “mpeparse” and the mpeevent outlet from that object to input data into the plugin.
Also, you need to turn on MPE in the plugin itself. See pics.
Screen Shot 2020-12-17 at 3.01.21 PM

Thanks for your support Peter!
That’s what my patch looks like, indeed. MPE is enabled in Surge. Now over to the Max Forums…
Cheers!

Oh well, it works with audiounit~. FYI, I did use [vst~ @prefer vst3] before, just in case.
Thanks again!

Twitter RSS Facebook