[Solved]: 64-bit Sensel App crashes on Windows 7 with vanilla SP1 and Directx 11

I installed the recent SenselApp for my windows 7 64 operating system with vanilla SP1 and directx 11. However starting the SenselApp it is always crashing.

Please find below an excerpt of the generated error.log. Sadly I’m no allowed as a new user to upload you the generated complete crash folder.

Looking into the error.log I can see that the crash happens in relation to the d3d11.dll module. Further analysis showed that the directx modle from within the Windows/system32 folder is used. This seems strange to me, as I installed the 64-bit version of your application and I would expect in this case that also the 64-bit version of directx will be used instead of the 32-bit version as it is currently…

Please fix this issue, as my new bought Sensel morph with inoovators overlay is currently more or less not usable for my applications as I cannot create any overlay maps.

BR
Axel

------------------------- error.log-------------------------------------------

SenselApp [version: Unity 2017.3.1f1 (fc1d3344e6ea)]

d3d11.dll caused an Access Violation (0xc0000005)
in module d3d11.dll at 0033:eeda33f4.

Error occurred at 2019-11-13_024100.
C:\Program Files (x86)\SenselApp\SenselApp.exe, run by Rashka.
30% memory in use.
4015 MB physical memory [2785 MB free].
8027 MB paging file [6568 MB free].
8388608 MB user address space [8388282 MB free].
Read from location 00000061 caused an access violation.

Context:
RDI: 0x07f6e988 RSI: 0x00000000 RAX: 0x054e9808
RBX: 0x004d8000 RCX: 0x004d8058 RDX: 0x00000000
RIP: 0xeeda33f4 RBP: 0x00000000 SegCs: 0x00000033
EFlags: 0x00010206 RSP: 0x07f6e8a0 SegSs: 0x0000002b
R8: 0x00000000 R9: 0x07f6e988 R10: 0x07f6e8d0
R11: 0xeed13148 R12: 0x00000100 R13: 0x00000100
R14: 0x00000100 R15: 0x00000000

Bytes at CS:EIP:
4c 0f be 52 61 41 8b f0 48 8b da 48 8b e9 48 8d

Module 1
C:\Windows\system32\xinput1_3.dll
Image Base: 0x00400000 Image Size: 0x0001e000
File Size: 107368 File Time: 2007-04-04_185422
Version:
Company: Microsoft Corporation
Product: Microsoft® DirectX for Windows®
FileDesc: Microsoft Common Controller API
FileVer: 9.18.944.0
ProdVer: 9.18.944.0

Module 2
C:\Windows\system32\ksuser.dll
Image Base: 0x6ff00000 Image Size: 0x00006000
File Size: 5120 File Time: 2013-03-01_024356
Version:
Company: Microsoft Corporation
Product: Microsoft® Windows® Operating System
FileDesc: User CSA Library
FileVer: 6.1.7600.16385
ProdVer: 6.1.7600.16385

Module 3
C:\Windows\system32\kernel32.dll
Image Base: 0x76b80000 Image Size: 0x0011f000
File Size: 1161216 File Time: 2013-03-01_024636
Version:
Company: Microsoft Corporation
Product: Betriebssystem Microsoft® Windows®
FileDesc: Client-DLL für Windows NT-Basis-API
FileVer: 6.1.7601.17514
ProdVer: 6.1.7601.17514

Module 4
C:\Windows\system32\USER32.dll
Image Base: 0x76ca0000 Image Size: 0x000fa000
File Size: 1008128 File Time: 2013-03-01_025042
Version:
Company: Microsoft Corporation
Product: Betriebssystem Microsoft® Windows®
FileDesc: Multi-User Windows USER API Client DLL
FileVer: 6.1.7601.17514
ProdVer: 6.1.7601.17514

Module 5
C:\Windows\SYSTEM32\ntdll.dll
Image Base: 0x76da0000 Image Size: 0x001a9000
File Size: 1731936 File Time: 2013-03-01_024820
Version:
Company: Microsoft Corporation
Product: Betriebssystem Microsoft® Windows®
FileDesc: DLL für NT-Layer
FileVer: 6.1.7601.17514
ProdVer: 6.1.7601.17514

Module 6
C:\Windows\system32\PSAPI.DLL
Image Base: 0x76f60000 Image Size: 0x00007000
File Size: 9216 File Time: 2013-03-01_024322
Version:
Company: Microsoft Corporation
Product: Microsoft® Windows® Operating System
FileDesc: Process Status Helper
FileVer: 6.1.7600.16385
ProdVer: 6.1.7600.16385

== [end of error.log] ==

Hi Axel,

Sorry to hear you’ve been experiencing this issue. This sounds like it could be an issue with your graphics card, the drivers or something along those lines. Here are some ideas:

  1. Make sure your graphics card drivers are up to date
  2. Try quitting other applications if they are open

Our 64 bit version uses both 64 bit and 32 bit libraries. Our 32 bit version only uses 32 bit libraries.

Please keep us posted!

Hi,

There are no problems with my graphics card, I already checked this.
Furthermore no other application has any issues with the installed directx, i.e. I could even play video games like Gothic 3, Oblivion and others with it. And these are using the directx extensively.

This sounds like it could be an issue with …, the drivers or something along those lines

I also suppose such, but I observe no problems with any other application I’m running on this system. I currently try to update my system, but up to now nothing helped.

BR
Axel

Hello,

I now updated to the most recent direct x for Windows 7 (which is directx 11.1), but this did not solved the problem.
Now I will be revisiting the graphics driver and try to reinstall it (even that it is the most recent), and see if this helps…
Next option would be to reinstall the complete Windows7, but this I do not realy like to do.

BR
Axel

Really sorry for the continued frustration, Axel. Please keep us posted once you’ve taken these steps.

Matt & Axel, I’ve had this same issue for months now, rendering the Morph to an occasional visit with frustrating results on my PC SP1 Windows 7, which is my main music composing DAW and the PC I need to tweek the Morph to become a viable controller for my work. I use it occasionally with a set-up I have made hooking The Morph up to my Mac, which doesn’t crash the app when sending data to the Morph. Very kludgy way to work in 2019!!! I have posted this a couple of times with now answers. So Matt, there are a few of us W7 PC users in need of a fix to the app driver.

John

Hi all,

I now got this issue solved.
For me it was essentially to update to a newer platform including directx 11.1 (KB2670838, replacing the directx 11 which is shipped with plain vanilla W7SP1) and a reinstallation of the most recent graphics driver (something must have gotten there wrong, since its last install).

I cannot tell if the directx 11.1 installation (KB2670838) is really needed, as I only reinstalled the graphics driver after this, so I cannot sort it our if the reinstallation of the graphics driver alone would have helped.

@Matt: Yes you were correct with your first assumption that it may be graphics driver related.

Thanks to all of you.
BR
Axel

1 Like

Very glad to hear the issue was solved. Thank you for keeping us posted, Axel.

@Nordym please try following the steps Axel laid out above. Keep us posted if you are still experiencing the same issue.

Twitter RSS Facebook