[Solved] Can't import maps to Windows

Hey, similiar to the “Can’t import a Sensel Map” topic, I recently installed on Windows. The app will not import a map: I can select a file (for Ableton), but the Open button will not function. Enter also will not function.

I’ve tried compatibility mode, running as administrator, reinstalling both the 32 and 64 bit versions, reinstalling the Ableton scripts, and importing the other Ableton scripts. Nothing works.

Is this a bug in the current Windows build?

Hi, sorry to hear you are experiencing issues. Since you saw the other topic, I assume you have the latest SenselApp, you have permission to the file. Here are some specific ideas for Windows:

  1. Make sure you have unzipped the file containing the .senselmap files.
  2. Make sure the file is selected in the file browser
  3. Again, not highly recommended, but you can go into %appdata%/…/LocalLow/Sensel/SenselApp/, make a copy of all the files/folders (as a backup), and then copy the sensemap into the folder corresponding to the Overlay. If you have any issues after doing this, just delete all the files/folders and replace them with your backup.

If you continue to experience issues, could you let me know what map you are trying to open and what version of the SenselApp you have.

Hi, I just bought my Morph at Moogfest and I’m having a similar problem.

Win 10 1809, Ableton Live 10 Lite, Sensel Morph with latest firmware, latest version of SenselApp.

When I attempt to import MusicProductionAbleton.senselmap, clicking the “Open” button does nothing. I tried moving the files manually, per the instructions above, to %appdata%/…/LocalLow/Sensel/SenselApp/. When I do that, the SenselApp won’t open correctly until I delete the maps from the folders I placed them in.

Overlay maps I make myself work fine. There seems to be something wrong with the Ableton Overlay maps. Is it possible to edit them in a text editor to make them work? Any other advice?

Thanks in advance

For me - yes. Use an editor that can show special characters like line endings - e.g. Notepad++. Then open a senselmap file that works and look which line endings are used there. Then open the one that doesn’t work. In my case these ones had different line endings. Do a search and replace and save. For me this worked.
Would be good if the SenselApp would understand Windows, Mac and Unix line endings on all platforms (so people can copy over senselmaps from e.g. Mac to Windows or the other way around).

1 Like

That worked! Thank you so much! For anyone else who has this problem:

-Open the file in Notepad++
-Click View->Show Symbol->Show End Of Line. Each line will have a “CR” and “LF.”
The “CR” is unnecessary
-Click Edit->EOL Conversion->Unix (LF). The “CR” will disappear.
-Import in Senselapp or transfer file manually.