Can't import a Sensel Map

#1

Hi,

It’s my first post here as I just received the Morph. So far it looks very promising, but I have a first issue:

I’m trying to import the Bitwig Overlays Maps. Under SenselApp, I’m able to open the import dialog box and to navigate to the folder where the Maps reside on my computer. Then I select one of them, say PianoBitwig.senselmap, but nothing happens when I click on Open. The box stays open.

I’m running SenselApp v0.16.14 on a Macbook Air with macOS 10.13.6.

Thanks for your help!

#2

Have you updated with the latest installer? We had (ok, I had) a mistake in the script that didn’t change the permissions. The latest installer should fix that. You can get the installer from our store or the git repo. You can use this direct download for mac for convenience’s sake, but I’m not sure how long that link persists.
(You should have gotten an anuto-email notice earlier this week that the installer was updated, but I can see how you might have missed it).

1 Like
#3

Hi @peter,

Sorry for the late answer! I received the notice and upgraded indeed, and it works now. Thanks!

However, you’re going to hate me:

I had to change my machine. Went for a Dell XPS 13 2 in 1, under Windows. The Bitwig script installation went fine, but I also tried to install the Ableton Live script and it showed exactly the same error than the previous Bitwig script…

Would it be possible than the same mistake sneaked into the Live script for Windows?..

Thanks again :slight_smile:

#4

Unlikely for windows, since permissions are a non-factor. Did you use the ones installed by the windows installer on your Dell? What happens if you use the repo’s files

#5

@jeremy fyi, I"m seeing this as well with Win10 using the Ableton remote scripts downloaded from the Sensel store. Open IMport, navigate the senselmap file , then just hangs. I’ll go and try the senselmap and the app reinstall from the repo…

#6

Hello,

Sorry to necro an old post, but I don’t think the storepage has the updated Windows scripts. I used Windows 10 with the morph and the overlay did not load when clicking ‘open’ in the import browser. There was no problem when I grabbed the overlays from the repo.

Cheers,
Soda

1 Like
#7

many thanks - that is exactly correct ! @peter it seems still true today that the Windows download from the store does not include the working version fo the Windows Sensel App. The version it includes will not load an overlay. The version that I pulled down from the repo did work though! just an fyi !

#8

Thanks for letting me know - that’s pretty odd. In order to remove doubt, I’ve reuploaded the installers from github to the store.

#9

Have the same problem here with my own overlays. Moved them from the Mac to the Windows computer and open didn’t really open anything. Then found “this file was copied from another computer and will be blocked” in the settings of the senselmap files. Clicked on “allow” now this text is gone from the settings dialog. Still not importing in the SenselApp though…
Senselmaps should be compatible between Mac and Windows, right? Using the latest version in both cases.

#10

Hm, ok, have exported a map and was able to import it again. Seems not to like my Mac overlay then?
Have uploaded one of them - any problems with that one?ContinuanoN C1-F2.senselmap (9.3 KB)

#11

Ok, got it working. I think the problem are the line endings. The Windows version expects LF, the Mac files use CRLF. Might be nice to allow both variants for Windows and Mac versions, so people don’t have to convert.