Timeout on read!

I just got a new (high-end MSI Win10) laptop for use with the Space Palette Pro, and I’m having problems getting 4 Morphs to be recognized when using an external powered hub. If I plug the 4 Morphs into separate USB ports on the laptop, they all work fine (simultaneously). The same 4 Morphs and the same hub work fine on another laptop. I’ve been using 4 Morphs through hubs for over a year on a variety of machines with no problem. I’ve tried 3 different hubs now, and all 3 work fine on an older laptop, but when I use any of the hubs on this new laptop, I get all sorts of “Timeout on read!” errors, randomly. After getting this timeout, other errors (e.g. “Failed to receive ack from sensor” and “Error reading frame data”) occur, but I suspect the problem is really just the initial timeout.

To review - the Morphs and all hubs work fine on an older laptop, but using any hub fails with random timeouts on the new laptop. Plugging all 4 Morphs into separate ports on the new laptop works fine - it’s only the combination of the new laptop and a hub that triggers timeouts.

How long is the timeout, when initially opening a Morph? I wonder if the timeout is set just a little too low, and that this new combination (MSI laptop + any hub) is exceeding the timeout.

Can the timeout be changed?


In case you’re wondering, the same random behavior happens with the Sensel App as well as my own code.


I tried increasing the timeout values in LibSensel.dll (changing/compiling/using the code in senselSerialOpen2() in github.com/sensel/sensel-api). That doesn’t seem to have any effect, unfortunately. Anyone have any other suggestions?


Perhaps it’s due to a particular USB controller? Comparing an existing laptop which works (i.e. with 4 Morphs on an external hub), I see that it has an Intel 3.0 USB eXtensible controller - 1.0 (Microsoft), while the new laptop has an Intel 3.1 USB controller 1.10 (Microsoft). Is there any possibility that the 3.1 USB controller (versus 3.0) would be the reason?


Hi Tim, sorry for the delay, yeah, it is likely the 3.1 USB. I have had some issues with USB hubs on USB 3.1 for non Morph devices too. My guess it is one of the following:

  1. The laptop drivers for USB 3.1 need to be updated (or improved) to support older USB hubs (including yours).
  2. USB 3.1 has different specs for power so it may have some strange behavior with powered and unpowered USB hubs.

I will spend a little time looking at this to see if we can do anything on our side, but it might require an update from MSI or Microsoft.

Hi Alex,

Thanks for the note. I just tried a super-old hub (I think it’s not even 2.0), and it seems to be working where the newer hubs I’ve tried (at least 3 different ones) didn’t. Interesting, perhaps using USB 1.0 is working around the issue? At least now I have an existence proof that it can work. I’m going to get a 3.1 hub, perhaps that will work as well.


Other USB 1.0 (or 1.1) hubs from my collection of USB hubs accumulated over the years don’t seem to work, but this one particular SIIG hub works in both unpowered and powered modes. Interesting.


Are Morphs still USB <2? If yes MTT vs STT could be a thing with several Morphs. (Edit: sorry, remembered wrong, USB 2 devices don’t seem to need a translator unit, so they should not be affected).

As far as I understood most USB 3 Hubs are bad when used with several USB < 2 devices with high bandwidth demands because only few still support MTT. Another problem could be insufficient power. Found a USB 3 hub from Elektron that still supports MTT - not sure whether it’s worth the quite high price though. Considered it for a moment but then found out that a cheap Sitecom hub that I still had works with several Morphs just fine (even in unpowered mode, when the Morphs are sufficiently charged). Also have two that don’t work at all though with more than one Morph, no matter whether powered or unpowered. No idea which “specs” these have (beside one being USB 2 and the other USB 3). Seems to be a lottery. :slight_smile:

I always use powered hubs, so power shouldn’t be a problem. In my testing I’m only plugging Morphs into the hub.

Thanks for describing the MTT situation and details, really useful!!


I’ve gotten 2 newer 3.1 USB hubs that appear to work fine with 4 Morphs:




1 Like

Not so fast… Even the newer USB hubs I got don’t fix the problem, they’re still occasionally intermittent. However, I’ve now discovered that using the one USB-C port on my laptop (instead of using any of the USB 3.0 ports) makes everything work reliably. (So far, at least.) Hurray!

Interesting and hopefully final detail on this issue - the USB-C port appears to work reliably, but only if I don’t use a powered hub for the 4 Morphs. It seems that a powered hub interferes in some way with the power that the USB-C port provides, causing intermittent failures when trying to access the Morphs. This is on an MSI GT75 8RG Titan laptop. It’s not the first time that I’ve attached large numbers of USB devices to a PC and had to experimentally determine how to make them work reliably.