[Solved]: Morph no longer connects to USB as device

Pretty new Morph, about a month. Worked great. As of two days ago, when I run the app, no Visualizer, no Send Map to Morph button. Held down button eight seconds - leds flash, green, off, red, off. Let button go. Push button once. Nothing. Push button twice, leds flash, green, yellow, off. Still doesn’t show up. Is not in the System Report USB device listing. Doesn’t turn on in the Audio/MIDI Setup MIDI display. Tried different cables, and different ports, one in hub, one on back of iMac. Touching the Morph doesn’t make any lights one on. Neither Thunder or Piano overlay works. It appears that the USB hardware in the Morph is no longer speaking to the computer.

Hey Neal, sorry to hear you ran into this issue. A few things to try:

  1. Quit any DAW or MIDI software and restart the SenselApp
  2. Make sure you are plugged into a USB port or powered USB hub. We have noticed some errors with some USB-C hubs and are looking into the issue further.
  3. Leave the Morph plugged in, hold down the button for 8 seconds, and then press the button again. All the lights on the Morph should flash. If they do not, let us know.
  4. If the Morph is recognized, you should see it on the top left in the menu bar listed as “Morph-XXXX”.

Let me know if you’ve run through all these steps and are still having the same issue.

1 Like

Matt,

  1. Did that repeatedly. Made sure no MIDI thing was running.

  2. I used a powered hub with no problem before this problem started. This problem occurs now with powered hub or if plugged directly into the iMac. Tried different cables.

  3. I did the button thing numerous times. The lights flash as described in the previous posting. When you change overlays the lights do that tear off put on thing. I think the Morph is doing its Morphy things, except USB.

  4. Any actual USB connection in either Audio MIDI Setup, System overview USB page, or the Sensel app does not show up. There appears to be no actual USB connection.

Thanks!

Neal

Do you have another computer you can test it on, so we can isolate if it’s an issue with the Morph or with the device?

A couple other things:

  1. Try unplugging everything but the Morph from the USB hub and see if it works. I know you’ve likely already tried this but just want to confirm.

  2. Make sure you do not have any apps that grab the serial port. It sounds like all other apps are closed, but if there was an app grabbing the serial port, then it would not work in the SenselApp.

If you’re still not having any luck, please email support@sensel.com and we can go through next steps.

Was this ever resolved? I’m having the exact same issue. I’ve done all the same things as Neal with no success. Works fine as a Bluetooth device but won’t show up via USB or in the App. I’ve done the reset, I’ve gone direct, I’ve used a different computer with freshly installed software etc. And as Neil said, not showing up in the USB list as a device.

Any help would be wonderful.

Keegan,

My solution, or what I did that made it work, was to disconnect the Morph from my iMac, and connect to my old MacBook Pro, and down load the software and set it up. It worked fine there. I then reconnected it back to my iMac, and lo and behold, it showed up as a usb device in Audio Midi Setup, and everything has been back to normal. On my iMac, the Morph did not appear in Audio Midi Setup, the Sensel app, or, I think, in the System description pages for USB from the About This Mac dialog box. In my communications with Sensel, I asked if it was possible for the Morph to have some sort of flag or state in the software that would lock up usb. Clearly hooking it up to a different computer and usb connection cleared whatever the locked up state was and it worked once more. My memory is kind of rough, but I think the circumstances when the original problem occurred was when I was frequently, like every few minutes changing the templates placed on the Morph. I noted in one of my emails that after the usb locked up, if you took off or placed a template you got the tearing off and putting on action of the LEDs but nothing else. No key press lights, nothing. Because the Morph returned to a functional state without any hardware changes, I assume this is a software problem. It is also probably one that is difficult to reproduce. You and I have. Connecting to a different computer was able to get the code out of its state and back to some normal situation. You mentioned connecting to a different computer, I don’t know what you have and I don’t assume my MacBook Pro was anything magical, but something did happen to get back to working again.

Neal

Neal,

Thanks so much for this.

So I had a discovery, which I’m mildly embarrassed of haha. I was using a different cable than the one supplied by Sensel. Once I tracked down and used the Sensel-supplied cable, it worked fine. This may tie into your issue in that perhaps there is a certain USB codec (new vs old) that is supported and another which is not.

1 Like

Keegan,

Glad things worked out. My experience as a software engineer in the olden days is that as long as it’s just you staring at the problem the solution remains unfound. Somebody walks in, waves their hands around and leaves and then suddenly things work.

As to USB, there appears to be lots of issues in music land with USB in regards to audio noise etc so who knows. The Morph is just low data rate MIDI but given the environment of multiple USB cables bearing MIDI and audio via a USB hub ending up in one cable into the computer (I have a real crazy setup) I’m amazed that it works at all.

And overall, I’ve been really happy with the Morph because I can finally play with a little more finesse and expression. And the choice of either a standard keyboard or the Buchla Thunder makes things far mor interesting. The Thunder makes me think differently which I like

Enjoy your now working Morph!

Neal

1 Like

@dadakopf @keegandewitt very glad things worked out for both of you!!!

Alas, I have had this problem too. A lot of 'USB cables" that ship with phone chargers and the like just have the power lines and not the data lines wired up, so you end up being able to charge and power devices but not talk to them. I have gotten to the point where I have a basket I throw USB cables in, and when I reach for one, if it doesn’t do what I want I cut it in half and recycle it so I don’t get bit by the same problem again.

Twitter RSS Facebook