[Solved]: Morph Won't Turn On, Connect Via USB

I was using my morph just fine summer/fall 2020, had to shelve it for a while, got the email today with the new presets, took it out of its case and plugged it in as always and the power light flashes for a split second, the lightstrip blinks, then nothing. I’ve tried the eight-second hold, and nothing happens. I can still pair it with windows 10 over bluetooth, but Ableton does not recognize it over bluetooth for me to test functionality (looks fine if I tap the Thunder overlay).

I’ve tried plugging it into different USB ports, my powered hub, even a recharger, but nothing happens except the quick blinks.

I’m open to any suggestions.

We resolved this issue via email. So everyone knows, Christopher uninstalled the drivers and rebooted his Morph. It seems to have revived it!

I’m having exactly the same isssue here but I never installed any drivers for Win10 just the Sensel App. Which drivers do you mean that were unisntalled?

@tomorrowsman do you know exactly what you uninstalled and rebooted?

I know another customer who had this issue removed one called “Sensel Midi”

A few other things to try if this is not an option (along with plugging the Morph in overnight as we discussed elsewhere).

  1. Quit any DAW or MIDI software and restart the SenselApp
  2. Make sure you are plugged into a USB port or powered USB hub. We have noticed some errors with some USB-C hubs and are looking into the issue further.
  3. Leave the Morph plugged in, hold down the button for 8 seconds, and then press the button again. All the lights on the Morph should flash. If they do not, let us know.
  4. If the Morph is recognized, you should see it on the top left in the menu bar listed as “Morph-XXXX”.

I’m not sure what I did but I’ve managed to get it working again on my PC via USB, still noth BT though. I managed to connect to my iPad and iPhone via BT, eventually, then tried again via USB on the PC and it worked. Maybe it just kicked it awake. or something.

Well whatever you did, I’m very glad to hear it’s working again via USB.

Regarding bluetooth, It can help to delete the device from your Bluetooth menu on your computer then, on the Morph, power it up and wait for the blue light. Then, double click on the power button to clear its bluetooth history. When it turns blue, try again.

Looks like clearing the BT history has worked. Thanks for you quick help.

1 Like
Twitter RSS Facebook