Unable to get MIDI connection over USB

Hey everyone, just got my Sensel Morph and absolutely freaking love it! But I am having an odd issue that I can’t seem to resolve. I’ll explain it simply and then list what I have tried since that might help explain it better anyway.

My Morph won’t register on Windows 10 (fully updated) as a MIDI device over USB, MIDIberry doesn’t see it and neither does Ableton, but the SenselApp works perfectly fine including the visualizer. However it DOES show up as a MIDI device when I pair it via Bluetooth, I much prefer to have it setup over USB though so that’s not really ideal.

Things I’ve tried:
Reboot PC
Restart All MIDI apps
Reinstall firmware
Uninstall via device manager and then plug it back in
Try the Win7 USB driver even though I’m on 10
Disable Win 10 Controlled Folder Access (ransomware protection that once in a while breaks stuff)
Update Ableton
Different USB port (it’s on a Razer Blade Stealth and no hub is used)
Reset the Morph
Install Ableton Live pack from Sensel direct
Manually remove every device under the Morph in device manager, then replug the Morph in so Windows grabs new drivers
Send an MPE map instead of MIDI map to morph

Any ideas of what I should try next? I haven’t tried another PC yet and won’t be near another one for a few days but once I am I will give it a shot there.

To be clear everything else works fine, using it as a keyboard, etc…

Edit: will be doing periodic edits to add what I’ve tried to the list.

Hey! Thanks so much for reaching out and sorry to hear you’re experiencing this issue.

First, please make sure you uninstall the Wn7 driver, as it could interdere.

I know you mentioned having MIDIberry installed. According to this helpful article, you may also need loop midi to set up a virtual MIDI port.

If you’re using Ableton, please make sure you’ve downloaded our control scripts and are following all of the installation steps here.

Keep us posted.

Thanks for the help here!

I went ahead and removed the Windows 7 driver, in fact I manually removed every device the Morph ads in Device Manager and then allowed Windows to reinstall everything, still didn’t bring MIDI up though. I can see the MIDI device in Device Manager though.

Are you sure loopmidi is safe? My enterprise firewall flagged it as malware (I’ve seen false positives before though) so I’m a little hesitant to install it.

I also installed the Ableton back, but Ableton itself still doesn’t see the morph as a MIDI device under “Midi Ports” so I can even enable Track and Remote.

I’ll update the list of things tried in my first post to reflect this.

Do you have other USB MIDI devices on this windows 10 computer? It really seems like there is something going on with the class compliant MIDI driver, since everything else is functional: you can connect to the Morph via SenselApp, it works as a keyboard, etc.
As for loopMIDI, I’ve never seen any issues with it - a lot of people use it. I’m guessing the malware detector does not like apps that create virtual connections like that. You can try LoopBe1 - A Free Virtual MIDI Driver
as an alternative. It’s only necessary if you are using Bluetooth MIDI because MIDIberry will create the initial connection, but the MIDI data needs a virtual connection to pass the MIDI data to another software.
If all apps are closed, and only MIDI berry is open, do you see the Morph as a USB MIDI device?

Just wanted to reply here to say that luckily the MIDI stuff all worked as it should on my desktop which is where I will use this 99% of the time, no issues at all that I could see. So it’s something specific to my laptop but I’m not sure what as it’s pretty standard overall (Intel i7-1165G7 with a 1650ti). Either way since this works on my desktop I’m happy!

Thanks for the update. This is a really unusual issue - if you ever have more information about it, I’d love to hear more.

Yeah once I have some time I will try a few more things on my laptop and report back, it’s definitely an odd one.

To answer your earlier questions, I don’t have any other MIDI devices on this one (at least for input, Windows has it’s default MIDI virtual output or whatever it’s called).

Also good to know about loopMIDI, I’ve had this firewall falsely flag things before so I’m not surprised.

Unplugging its USB connection and plugging it back in will often do the trick. … If your MIDI device does not appear in the utility, consider reconnecting the cable, connecting it directly to your computer, or trying a different USB port. PC: Device Manager. Right-click the Windows icon and choose Device Manager.. .

All of these things were tried multiple times with no luck, it works fine on my desktop though so I am OK with that as I basically never use it on my laptop. But no other port would work, a new cable would not work, reinstalling drivers would not work, etc…

Twitter RSS Facebook