Morph won't connect via Bluetooth

Gah! I have a Mac Mini M1 + MacOS Big Sur.
When I try to pair my Morph with the Mac, the OS’s Bluetooth panel says, “Connecting” then “Connected” then “Disconnected” multiple times before then giving up and failing.
Is this a Big Sur compatibility issue? Or M1 silicon issue, or what? Really struggling.

Oh, and it won’t connect over USB either. So frustrating!!

Andy

Hey Andy, sorry for your frustration.

What are you seeing when you try to connect via USB? If the App isn’t detecting the Morph, please try the steps below.

  1. Quit any DAW or MIDI software and restart the SenselApp
  2. Make sure you are plugged into a USB port or powered USB hub. We have noticed some errors with some USB-C hubs and are looking into the issue further.
  3. Leave the Morph plugged in, hold down the button for 8 seconds, and then press the button again. All the lights on the Morph should flash. If they do not, let us know.
  4. If the Morph is recognized, you should see it on the top left in the menu bar listed as “Morph-XXXX”.

If that gets working, can you please confirm if your firmware is up to date? That might impact the bluetooth issue.

I’m also wondering if you have connected it to any other device via bluetooth? It can help to delete the device from your Bluetooth menu on your computer then, on the Morph, power it up and wait for the blue light. Then, double click on the power button to clear its bluetooth history. When it turns blue, try again.

Thank you Matt. I’ll try your steps.
Regards
Andy

Hey Matt,
Tried the holding down for 8 seconds thing. Yep, lights briefly flash on, but no joy seeing it from the Sensel app. I’ve plugged the Morph into both a hub and directly into the Mac Mini. Neither works.
But… when I tried the double clicking of the button to clear the Bluetooth history, it then connected to my Mac, without repeatedly disconnecting! So, some small progress…

Regards,
Andy

Hmm, well I’m glad we got it connecting via bluetooth.

As a next step, lets try deleting all traces of the SenselApp and then reinstalling.

  1. Quit Sensel App
  2. Go to Finder
  3. From the top menu, choose Go->Go to Folder…
  4. Copy and paste this and press go: ~/Library/Application Support/unity.Sensel.SenselApp
  5. Delete all files and folders in this directory. (You can make a copy if you want to save any)
  6. If you have any other folders in ~/Library/Application Support/ called Sensel or SenselApp, please delete them.

Then please reinstall and see if the issue persists. Appreciate your patience as we work through this.

Some more info.
I have another Mac (MacBook Pro, 2018, Intel-based, MacOS BigSur) so I decided to try the USB connection with that. Same issue. SenselApp doesn’t see the Morph. I’ve tried three different USB cables also. I’ve tried connecting it straight to the MacBook, and via a USB-C hub. No joy.
When I power on the Sensel Morph, the power light briefly flashes. Tapping the Morph doesn’t trigger any LEDs (maybe it doesn’t normally?)

I also repeated the steps you laid out, on my MacBook, in order to uninstall the SenselApp first.
Andy

Hi Andy,

When you say you tried connecting it straight to the Macbook, do you mean it has a USB-A port?

Could you share what kind of USB hub you are using? We think that might be the issue.

Here is a cheap hub that we’ve confirmed works: https://www.amazon.com/gp/product/B017N3KNP8

I know it’s a bit of a drag, but if you’re willing, it might be worth ordering to see if it solves the issue.

Thanks,
Matt

Here’s what I’ve tried:
Mac Mini M1
Bluetooth = works
USB A via OWC Thunderbolt 4 hub = fail
USB A direct into Mac Mini M1 = fail

2018 Intel MacBook Pro
USB A via USB-A → USB-C adapter plug = fail

Joy!

Thanks Andy. Could you please also try charging the Morph via a wall charger for several hours, and then trying to connect again? It’s just a theory, but I think there is a chance it will help for the device to be close to fully charged.

I’ve left it charging overnight (although it’s hard to tell if it’s charging; no LEDs come on during charge - is this normal?) but still can’t connect via USB.

The USB issue is really mystifying. Does it show up as a device in the system report (apple menu → about this mac → system report button)?
Click on Hardware, then USB then cmd-F to find the word “sensel” to see if is listed in the USB devices.

Hi again,
Thanks for persevering with this issue!
I’ve tried connecting the Morph to my:

  • USB 2 hub: Sensel not found
  • USB 3 hub (with Thunderbolt 4 support - the OWC TB4 hub): Sensel not found
  • Mac Mini M1 USB port directly: Sensel not found
    Andy

Can you contact support at sensel.com - I think we’ve reached the limit for the forum!

Hi
I’m still struggling with my Morph. I’ve tried it plugged into a Mac Mini M1 silicon, via a USB hub and directly. I’ve tried it plugged into an Intel MacBook Pro (via a small USB hub). I’ve tried multiple USB cables… Neither machine sees it (I use About This Mac-> System Report… USB).
Help! Is it dead? I still don’t know if it’s even on. I know it powers off (red LED comes on). But when I power it on, the LED flashes green momentarily and then goes off.

Andy Deighton

Again - Can you send a mail to support-at-sensel.com and we can better help there. It really sounds like there is a usb connector issue.

Sorry Peter, I thought I was responding to the thread that we’ve had open since April 22nd. I was just adding to it. OK I’ll resend it all to the address you provided.

Andy

Twitter RSS Facebook