Kenton Midi USB host mkII not recognizing Sensel Morph

I bought the Kenton Midi USB host mkii based on your recommendation. However, I only get the blinking light on the host when I plug in the Sensel Morph. When I plug in my Arturia Keystep, it recognizes it and the light stops blinking (stays solid). What am I missing?

Very odd - we used it successfully for days at Moogfest. I would make sure that your firmware is updated on your Morph to duplicate the conditions on the Morphs we used the Kenton with.

Yes, I bought my Morph from you at Moogfest. That’s why I picked the Kenton to connect to my standalone instruments.

The firmware is up to date (0.19.180). The Morph blinks twice when I plug into the USB port on the Kenton but it doesn’t finish the connection. The indicator light just blinks.

All other controllers connect easily to the Kenton with a solid, not blinking indicator light.

I know this may sound primitive and possibly annoyingly obvious, but … try a different USB cable. If that fails, please contact Kenton and cc peter at sensel.

Always worth a try. Yes, I tried several different cables and all have the same result. The USB cable that came with the Morph connects in a flash to my Keystep. Doesn’t seem to be a cable issue. I’ve requested a return to Kenton, assuming there’s a problem with the USB host.

Ok. Perhaps there is a firmware update on the Kenton device itself? One possibility is that your device has a slight difference in firmware from the one that we have, and therefore doesn’t work.

That’s what Kenton suggested. But a firmware upgrade didn’t work. But if others have this problem, the firmware is available here:
The latest firmware can be downloaded here:

Hi, same problem here.
You’re saying that firmware upgrade doesn’t change a thing, so nothing left to do with Kenton, right?
Then which other device should we go for?

Can you provide the code for the firmware version in your Kenton usb midi host? I’ll try to request the same SysEx file from Kenton.

I returned the Kenton. Kenton tried to help me connect but no luck.

Then I ordered the Excel Valley MIDI USB DIN
Converter - PCB with Enclosure Kit. Works beautifully now.

Great to hear you have a working system!

For the record, I queried the firmware value on my Kenton:
according to their manual, I sent the sysex command
F0 00 20 13 13 60 F7
(decimal: 240 0 32 19 19 96 247)
which returned
F0 0 20 13 13 6f 32 30 30 36 F7
(decimal: 240 0 32 19 19 111 50 48 48 54 247)
The important items are 32 30 30 36,
so the version number on my unit is 2006, according to the kenton manual.

If you have an earlier version, you can flash the mkII update, using the file from this webpage. Not sure why that didn’t work for woodrowhood!

Firmware upgraded on the Kenton, but still not recognizing the Morph, even in slow charge mode.

I have been trying to use my Kenton USB MIDI host MKII to connect the morph to my op-1 and am having the same problem. Playing the op-1 is the reason I bought the Morph. I have no real need for it other than that. I’ve spent some real time and money now work with a product that on paper says it should work, but doesn’t. I have excepted the fact I won’t be able to play my op-1 while not connected to power, but now it seems I can’t play it at all and I’m stuck with a device I don’t need.
The kenton works to play my DSI Tempest via Morph but not my op-1. I can also play the op-1 via iPad and camera connect kit. I don’t own a computer so that’s not an option. All firmware has been checked/updated in past few days. All cables have been swapped out. Seems like its the morph to me. Any ideas? Really hoping to be able to move forward with this product even though its been a hard start.