Upgrade to v19 Keyboard not Working, Morph Not Connecting

I tried to reset the morph because the new update was causing me to have to press very hard to get the keyboard overlay to work. I even tried to revert it to the last upgrade I had on it. That didn’t work so I put v19 back on it. But now it doesn’t work at all except when plugged into my desktop. Nothing can connect to it via bluetooth - it doesn’t even show up when they scan. Not my phone, not my laptop, not the Tab S3 where i normally use it (had to forget the connection in order to test other devices). Help???

Hello, it sounds like you need to enter pairing mode onthe Morph. Please delete the pairing of the Morph from any devices it was previously paired with. Then turn on the Morph until the light turns blue. Then press the button twice. All the LEDs should flash and the Blue light should turn on again after 3 seconds and slowly switch between bright blue and a darker blue. Then you should see the Morph listed on your devices. The Morph can only be paired with one device at a time.

If you have any further issues, please contact us at support@sensel.com so we can get more information about your setup.

I am seeing the same issue, will give the re-pairing a chance…