Firmware update fails

Windows 10 update 0.8.82 stalls (consistently) at “Bluetooth Progress: 27%” App version 0.10.6

1 Like

Hello, thank you for reporting the issue. Please try the following.

  1. Quit the App
  2. Reset the Morph by pressing the button for 8 seconds and then pressing the button to start it again.
  3. Open up the App again and go to Morph Settings. Before pressing the update button, wait until the White LED has turned off on the Morph.
  4. Then you can press the update button.

If you continue to experience issues after all of these steps, then please contact us at

Hi Alex,

Thanks, resetting the morph did not help, same problem after rebooting both the morph and the host machine. However I was able to update the firmware from a different machine.

I am now running into a different problem though. I cannot for the life of me pair the morph. I have had the morph successfully paired previously, but no luck now.

I turn the morph on and I get a solid blue light

  1. does a solid blue light indicate that the morph is currently paired
  2. or does a solid blue light simply indicate that the morph is in bluetooth mode (i.e. not necessarily actively paired)

Double tapping the power button does not set the morph into pairing mode (i.e. no flashing blue - blue light just stays solid).

I understand that I can only pair to one device at a time, but I don’t have any actively paired devices. Also I assume double tapping the power button should force the morph to drop any paired device and go back into pairing mode - this does not seem to be working.

Any ideas? Multiple devices running multiple OSes and nothing sees the morph. Is there some other hard reset other than the 8 second power down? I have of course already tried to “turn it off and turn it back on” many times :slight_smile:


I am glad to hear you could update on another computer and thank you for letting us know that resetting did not work on your other computer. We will continue to look into that issue.

As for pairing, it sounds like you are doing all the necessary steps. I do have one test for you to run that will help me diagnose the issue.

  1. Turn off the device when unplugged from USB
  2. Turn on the device (all the lights should flash)
  3. Blue light should turn on.
  4. At this point, double tap the button. Do all the lights flash? If not, please let us know.

If it does not flash or you still get a solid blue light, try tapping the Button once. It should flash either Green or Red to indicate battery level. If nothing flashes, please let us know. Thank you for your patience.

Hi Alex,

  1. check
  2. check - all lights do flash
  3. check - solid blue light
  4. fail - lights do NOT flash - stays solid blue

single tap also fails to change from solid blue light

I have one additional piece of debugging info that may be helpful. After 2. and just as 3. begins (within a second of 3. starting) a single tap DOES show green and a double tap DOES reset (i.e. all lights flash as in 2.) - however, as above the system continues on to solid blue light. Also once 3. has been active for more than approx 1 second, it will stay blue for ever, and no amount of button pushing will produce any deviation.


Thank you for performing these tests. You should receive an e-mail from our support team early next week for next steps.

If any other customers are experiencing this specific issue (after the Blue light turns on, you cannot enter pairing mode by pressing the button twice or see the battery status by tapping the button) please contact us at

After reviewing, we have decided to pull the BLE update while we look into the problem and release it at a later date. Please download the new version of the SenselApp from (currently 0.10.10) and it will allow you to update to the latest firmware. Thank you for your patience.

I’m having the same problem. Only I don’t have another computer to try it on. I’m on Firmware version 0.6.22. When I click on update button, all the lights on the morph flicked (the white bar lit up) and downloads. Then it just sits there forever on the “Do not disconnect Morph. Status: Restarting…” message. I left it open last night and it was still there this morning. I followed the restart instructions above and downloaded again. Still not working…

OK - this is interesting. I had it plugged into a USB hub that was plugged into the USB port on my monitor because my desktop front panel wasn’t working. I finally powered off the pc and figured out what wrong with the front panel (unplugged after recent PSU failure). When I plugged the Morph into the front panel, the update worked perfectly. If anybody else needs to know the current firmware version number, it’s 0.12.78.

Hi there,

I’m having an issue on a Morph. I’ve got one with a Firmware version 0.6.22, and when I try to update the firmware with windows 10, it does the BLE update and then stay stuck on the restarting step, with the message “Do not disconnect Morph. Status: Restarting…”
I didn’t succeed to pass this step, and cannot use it on linux anymore.

I’ve tried what has been explained before, but without success.
I’ve also tried on another computer, and i have the same issue.

Could someone help me, please ?

Hello, thank you for reporting the error. This sounds like the computer is not properly disconnecting the USB on restart. I would try a different USB cable if you have one available or make sure not to plug into a USB hub if possible. We will also look into this issue further.

If neither of those work, for the meantime, here is a workaround:
After the BLE update has finished and you are on on “Do not disconnect Morph. Status: Restarting…” for 5 seconds, unplug the Morph and plug it back in. This should restart the Morph for you and the update should continue.


Thanks for your answer, but I’ve tried both solutions you proposed and it doesn’t seems to fix the issue :frowning:

I am sorry to hear this did not work. Please contact us at so we can get a bit more information about your device and I can send a future software update that may fix this issue with some Windows 10 machines. If there is an issue with the device, we can also discuss replacing the device. Thank you for your patience.