Buetooth midi not working under linux

hello,
i have sensel with latest firmware (0.19.216) + debian buster with bluez (tried bluez 5.50 and latest 5.55) compiled with --midi-support according this tutorial: https://tttapa.github.io/Pages/Ubuntu/Software-Installation/BlueZ.html

i can even see morph in my qjackctl midi connect menu, but when press anything (i have music production overlay which is sending both midi notes and cc) there is no midi communication/output. i tried to monitor midi events with qjackctl and pure data and it is just silent.

my dmesg says:
[ 2964.627936] input: Morph-5191 Mouse as /devices/virtual/misc/uhid/0005:2C2F:0004.0007/input/input27
[ 2964.628334] input: Morph-5191 Keyboard as /devices/virtual/misc/uhid/0005:2C2F:0004.0007/input/input28

any idea how to get more precise info if there are any data flowing from sensel to computer?

anyone had a luck running bluetooth midi under linux/debian? i would really appreciate this layer working :slight_smile:

ev. thnx for info & regards!

1 Like

Exactly the same here under Ubuntu 20.10, bluez compiled with MIDI enabled, I can see the Morph in qjackctl but that’s it. Can’t connect with the controller in Bitwig. Following this thread with the greatest interest :slight_smile:

Twitter RSS Facebook