Gliding to wrong notes in bitwig

Hello, I have the bitwig script installed and running and the map sent to the morph with the piano overlay.

Gliding between white notes with black notes in between works fine, gliding from g to a is a full note step and works. However, gliding from e to f should only be a half note step, though my morph goes all the way to f# since it moves a full note step upwards going from e to f with my finger. What did i miss here? Why does my morph think that e# exists?

Love the product otherwise, thanks for the help in advance!

1 Like

You will probably want to change to the “Jump” mode of pitch rounding in the Morph settings.

Hi! The same problem here, I bought Morph at the start of their selling and had this problem appeared not only in Bitwig (that I purchased later), but in every case where mpe is possible. So I feel like it is not a bug, it is the way it works (and it is totally frustrating, because I have no hope they will fix it in update), cause it goes on from the start and only blind or deaf doesn’t see/hear the problem here. I wrote about it couple of years ago! With the latest update the problem didn’t go away and I can describe it in details with settings in sensel app:

  1. If you choose “MPE Channel Start” to ch1 and “MPE Channel End” to ch16 (as it supposed to be, if you want 16 ch polyphony for some reason) and check the box “slide out of Areas” (if you wand bend pitches on sustain) and any setting of MPE Pitch Round (there is no difference with such config, nothing changes) - the whole width of morph will be equal to half tone (wtf!?), changing “MIDI Pitch Bend Range” doesn’t change anything.
  2. If you choose “MPE Channel Start” to any channel above 1 (2,3,4…etc) and “MPE Channel End” to ch16 (then you’ll lose some channels, but it’ll be all good if it works, but it doesn’t) and check the box “slide out of Areas” (if you wand bend pitches on sustain) and any setting of MPE Pitch Round (it can be even “none”) - if you want to glide from C to E, you have to move your finger from C to G#, and if you move your finger to E you just made whole tone from C to D. changing “MIDI Pitch Bend Range” doesn’t change anything WHY SENSEL WHY???
    It is SO frustrating to update morph and find nothing changed for years!!! No settings changing helps!
    Really, is it the way it should work?? Don’t you see it is illogical??

I actually did get a response, even though it does make the glides a little less fluent (but still totally usable) you have to set the gliding behaviour to „jump“ in the global tab, that way it actually recognizes every key as an individual key rather than just the distance from the route note you started to glide from

It doesn’t actually solve a problem at all. If you use jump mode every time you cross the line of note zone on piano roll layout sensel just retriggers note, how are you supposed to play any long notes with physical models of strings or any “solo” instrument…the whole point of mpe controller (with piano roll for example) is to give an opportunity to play as expressive as possible, how can you play expressive if you can’t navigate precisely? Why should I do that f* math each time with “how much halftones should I go up to…” before I slide to the next note I need to slide to? It is fundamentally wrong.

Jump mode will smoothly glide in firmware 19.298. Make sure your firmware is updated.

My firmware is up to date, problems I described are based on the latest firmware: when “slide out of areas” box is checked it glides to wrong notes, when it is not checked it retriggers. All with MPE pitch round “Jump”.

Ok, problem solved!!! I’m so happy now!! I just reinstalled everything: app, bitwig scripts and firmware and now it is finally work as it supposed to! Thank you Peter for your patience!

Great to hear. Thank YOU for your patience.

P

Twitter RSS Facebook