Bitwig Studio 2.5 Latest Sensel Firmware - incorrect pitch tracking MPE

#1

The morph is not triggering the correct pitches as set in the Bitwig MPE map. For example, I play C4 and it’s fine but then play the B a half step lower and it triggers F5. This happens on several notes as you continue down the octave. I’ve tried deleting and reloading the maps and resetting the morph as a controller and nothing changes.

0 Likes

#2

Helllo, I’d should add that the non MPE maps seems to track correctly and the visualizer shows that the Morph is tracking correctly. Any feedback on what might be going on or solutions would be much appreciated. Thank you!

0 Likes

Dual Lightpad (10x5 MPE)
#3

Same here. It sounds like it’s an issue with the controller script for the Morph. In my setup, I’ve solved it by switching to the Seaboard Rise controller script (turning off the Morph script which comes up automatically). But it’d be a good idea to create a new controller script.

0 Likes

#4

This really sounds like the Morph was not flashed with the map files that go with the script. Our guide details this: http://guide.sensel.com/morph_software/#flash-the-morph-with-maps_1

I just double checked by loading the Sensel “MorphMPE” script in Bitwig. I flashed the morph with the Piano Bitwig MPE map, then recorded some MIDI clips in bitwig. You can see the correct notes are recorded.

This example has the octave offset to “36” or C1 (Pressing the “-” button on the piano overlay):
bitwig_recordC1

This example has the octave offset to default “60” or C1 (Pressing the “-” button on the piano overlay):

As you can see all the notes are sequential, going left to right on the piano overlay.

0 Likes

#5

If you can provide some similar evidence of your issue, that would be helpful!

0 Likes

#6

Hi Peter,
Thanks for this information. I grabbed the original map file and flashed the Morph and it tracks correctly, however, the map file that I made by modifying the original still does not. All I did was turn off some of the top row buttons and set the pitches to start at C2. I’ve attached a screenshot of Bitwig MIDI recording as I played up the Morph from C2-C4. All notes are set correctly in the map. Any ideas why it would track this way?
Thank you

0 Likes

#7

For various technical reasons we translate all the notes from the Morph using the bitwig script before they go to the MIDI clips. That’s why we have special .senselmap files provided in the Bitwig Script installer. If for some reason you want to customize the map, you should start from the .senselmap file for Bitwig, not the default Map for the overlays.
You’ll notice in the Piano Overlay map for Bitwig starts at C5:

Hope that helps.

1 Like

#8

Hi Peter, Thanks for the info. Yes, my map was modified from the Bitwig MPE map. All I did was change the notes in order to have the default start at C2 rather than C5. Is there any reason only changing the pitches to be a couple of octaves lower would create pitch tracking issues? Does the script need to be updated with that information too or should it work with that type of modification in the map? Thank you!

0 Likes