Midi latency with drum pad

Hello,
I am trying to use Morph “drum pad” overlay.
I am actually dissapointed: response is not linear, and I get missed taps and extra spurious taps. Sounds horrible when used with Abbleton Live 10.
Unfortunately this is even worse: the midi latency is horrible, probably above 100ms (claimed 2ms is a nice number but I don’t get that, maybe 2ms is an idealized analog scan rate…).
I was hoping to use it as a drum pad in music production. This is so far from possible, I am considering going for something else.
Anybody had a better experience? Thanks

1 Like

I don’t have any latency issues. I use two tea spoons on the drum pad and can produce pretty fast rolls. :drum: :ok_hand:
However, I do get spurious missed hits as well as extra ones. I don’t think it is specific to the drum pad though. It’s just more noticable due to faster playing.
It’s not so bad that it would render the Morph unusable, but it is pretty annoying. Definitely not fit for a professional environment, when you have to repeat every other recording due to device malfunctioning. Sensel should definitely look into this and fix it.

Thanks Andreas, I will try it with an external synth rather than the Ableton Live software synth. Maybe latency is betther then. Thanks also for feedback on spurious hits, I suspect that can be improved with a new firmware release. Let’s see how it evolves…

I’m just curious if this behavior is over Bluetooth or USB? I had similar problems when trying to do MPE over Bluetooth with other overlays. They went away when I switched to USB.

1 Like

I use it with the USB. My laptop is a Surface Pro with Intel i7.

Make sure to uncheck the high resolution midi cc during setting.
This will provide the fastest response.
It will still miss some strikes from time to time, but barely noticeable in my case.

What do you mean, Federico? Check or uncheck? AFAIK, the drum pad has the fast setting by default.

Yes, You’re right.
For a moment i forgot the post was about the drum overlay.
What i mean is to make sure to not check the 24bit cc if this is the case.

So sorry, I can’t find the 24 bit cc setting. I am new to this. Any hint to get me started?

Twitter RSS Facebook