MPE and Sensel Morph in Presonus Studio One

Does anyone here use a Sensel Morph in Presonus Studio One version 5?
I’m trying to get the Piano Overlay MPE MIDI to work but without success so far unfortunately.
Two of my MPE compatible Virtual Instruments, Arturia Pigments and Voltage Modular, will readily take the MPE from the Morph when in stand-alone mode but when they are used as VST plugins inside Studio One, they do not.
Neither VST2 nor VST3 versions are getting MPE from the DAW.
The Studio One ‘MIDI Monitor’ is ‘seeing’ the commands coming in, but they’re not getting through to the plugins.
In ‘External Devices’ I have checked the MPE box but Studio One is behaving as though I HAVEN’T.
In other DAWs, Ableton Live, Bitwig, Voltage Modular, these plugins are responding just fine to the Sensel Morph in MPE mode.

1 Like

I’ve been through this both with Presonus Sphere Expert Chat AND with Presonus Tech Support.
Expert Chat tried their hardest but with only a Roli amongst them, they could not test for this MPE incompatibility problem.
Tech Support informs me that they have no MPE controllers at all with which to test for problems in Studio One.
I presume that Someone amongst the developers at Presonus has some sort of capacity to check the workings of MPE within their software.
Hopefully there might be some communication between Presonus and Sensel over this at some point.
Somebody has to Know what is going on.

Thank you @Kozmyk. I’ll see if we’ve had any contact with them or can open up a line of communication.

1 Like

Hey @Kozmyk - I wanted to confirm that we reached out and will keep you posted.

Not sure if it’ll help, but I came across this article from Sound on Sound which dives into setting up MPE. He’s using a ROLI product, so these might be steps you already tried that aren’t working for the Morph.

It’s behind a paywall, but you can buy the article for $1.49 USD.

Thanks,
Matt

1 Like

Hi Matt

Did I mention that Robin Vincent of Molten Music put my problem to Lee Boylan Presonus Product Specialist, LIVE on his stream the other day?
From Lee’s reaction I got the impression that they’re none too confident about their MPE implementation.
He mentioned the inconsistencies in the MPE protocol standard …
At least he didn’t try to hide it eh ?

Thanks for the SOS article info I’ll certainly take a look at that.
If I’m getting MPE from my Sensel Morph through Pigments and Voltage Modular through Ableton Live 10 but not through Studio One then it’s pretty certain that the incompatibility is between Studio One and the Morph isn’t it ?

I note that you have provided scripts for using the Morph with Ableton Live and with Bitwig; and I’ve installed those scripts and Morph Maps for when I use those DAWs. (Ableton Live 10 Standard and Bitwig-8)
Could it be that a script of some description is required before Studio One can deal with the Morph’s MPE output or is it that Studio One is only partially MPE compatible in it’s present form ?

I say partially compatible because Tommy, one of Presonus’ Sphere Product Specialists, had mentioned that he had a Roli and was not getting the same problems.
So far, Tommy is the only Tech Support at Presonus that actually has an MPE device at all …

I’m a little behind with things at the moment because a council electrician dropped the power on me last week and something blew in my computer.
I’m slowly getting it back together.
I bought a new PSU buy it appears that it was the GFX card that was hit … that and a corrupted BIOS
Mercifully my motherboard has an onboard graphics chip so at least I can drive my monitors.

Anywhoo … that’s been my focus this last week.
Getting the PC working again.
It’s still in pieces all over the floor as I type this now … :crazy_face:

Be Safe
Koz

1 Like

Well, this gives me a head’s up on the topic before I ventured to try MPE in Studio One as well. Thanks.

I’m a recent Morph purchaser and just updated my S1 in order to work with MPE in a DAW I commonly use (the other is Live-- still waiting on 11 for MPE). I so wish I had reviewed this thread before I upgraded S1, as MPE support is the only reason I upgraded. The Morph does not work in S1 for me at all. Now I’m stuck using Bitwig 8-track until something gives with S1, or Live 11 is released.

Love the Morph, though. I just wish Presonus would get it together, or Sensel could help facilitate that!

Thanks for your recent purchase. I definitely understand your frustration. We got a Morph in their hands a couple weeks back, so hoping they’re able to resolve these issues soon!

2 Likes

Great to hear, Matt. Thanks for your efforts!

That’s good news Matt.
You guys at Sensel are truly on the ball.
Now that ball is in Presonus’ court.
Hopefully we’ll get a fix soon.
:crossed_fingers:

I submitted a ticket to Presonus in hopes of expediting this. I’m not sure I believe them, but they said they don’t have a Morph to test and can’t do so. They then told me that Sensel should download the S1 trial and do their own tests. LOL; very helpful.

I was also told that MPE in S1 requires vst3 plugs. I informed them that was what I was trying to use, to no avail.

Good times.

One person will tell you that MPE only works in VST2 then the next one will tell you that it only works in VST3.
In other words, they don’t know …
I went through the whole tech support thing with Presonus.
Some of the Sphere guys tried their best but had to hand me over to Presonus Tech Support and they came up with nothing.
Now that Matt here at Sensel has got a Morph to them at Presonus maybe they’ll get up off their arses …

1 Like

Presonus followed up on my ticket today and confirmed they now have a Morph and that the addressing of this is in process, with unknown ETA. A welcome development, at least.

2 Likes

@Kozmyk @anxiousmofo we made a video that might prove useful!

Thank you! Presonus clearly needs to do a lot to expand/improve their MPE implementation, but this is a start!

1 Like

Hi Matt
Thanks for the heads up.
Yes, I saw the video as soon as you posted it.
The best I can get out of Studio One and Morph with MPE is that the ‘Y’ function will work for the 4th note held down only and Only that note.
To get ‘Y’ to function again , another 4 notes have to be held down sequentially.
So basically Studio One still isn’t doing MPE for me.

The only thing I haven’t tried is a complete clean reinstall of Studio One and I’m very reluctant to consider that at this point.
Be Safe
Koz

P.S.
I couldn’t reply to the email, the return address was rejected

1 Like
Twitter RSS Facebook