No way to update firmware

I wan’t to update my Morph firmware and I believe there is suppose to be a button or something to do so in the SenselApp, but there is no button. How can I update?

You should see it when you select the connected Morph in the sidebar. Have a look at the screenshot here: SenselApp - Sensel Morph Documentation

You might need to show the sidebar with the button in the top left if it’s currently hidden.

Yeah the red button isn’t there. I’m on the latest SenselApp, and I reinstalled it and emptied the preferences and tried different cables and USB ports. Still no luck.

what are the vitals on your computer? Operating system, etc.
The firmware update requires an internet connection to ping our servers to compare your firmware version number with the latest version number. It seems that it could be that the connection is not successful for some reason. This could be some firewall or internet security issue perhaps.

We have also found that there are some possible weird serial issues that prevent the firmware and battery levels from being read. If this is the case, your firmware will be listed as 0.0.0.0 and battery levels at 0%. We helped a user a while ago and found that the Native Instruments NTKDaemon may cause interference with the Morph connecting to the SenselApp. It will show up, but when you look at the Morph-XXXX settings, you’ll see the firmware is listed as 0.0.0.0 and the Battery is 0%.
The workaround was to uninstall the NTKDaemon startup app and restart the computer. Then the firmware version was successfully read and the firmware could be updated.
Weird, I know. But it worked.

Windows 10, i7-4790, 8GB RAM, Radeon RX 560

I don’t see anything about a NTKDaemon in Task Manager or Startup apps, or Services. Restarting the PC also doesn’t help

What is the address that it needs to check for updates?

I disabled the Windows firewall, and still no luck.

Also, usually now when I click on the visualizer it shows a blank white screen. Before it was sometimes giving a message that I must update my firmware. Once today it briefly flashed the visualizer grid but it disappeared. If I click on the Morph-6995 name on the sidebar, then clicking on the visualizer afterwards does nothing. But clicking on the name causes it to begin flickering about every 1 second like it is redrawing.

Lately I haven’t been having a problem with it displaying 0 for the firmware or battery.

This sounds like either a flaky connection issue or software issue messing with the serial connection. If it was a mechanical connection issue, you would see the lights flash on the Morph unexpectedly as it gained/lost power. Have you tried disabling any of the startup apps from the Startup control panel?
The flickering drawing issue in the Sensel App could also be something unusual with the video card - are the drivers for the video card up to date?

Well, I finally solved the problem, sort of! At least I figured out a way to make it work. I’m surprised I didn’t figure it out sooner.

If I unplug the Morph before before starting the SenselApp and then plug it back in after I have started the SenselApp then I have no problems. I don’t get a solid white indicator light on the Morph, I am able to send maps, I am able to view the visualizer, AND I finally saw a red update button and successfully updated my firmware!

I don’t know why I have to unplug before starting the SenselApp, but once the app is started I can edit and send maps as much as I want while it is open.

1 Like

Glad to hear you came across this fix. Thank you for sharing!

Twitter RSS Facebook