[Solved]" Major Issue with New Morph that seems like its "sleep mode"

I’m having an issue where I have to “send map to morph” to get the morph working again in Bitwig after it working just a few second prior. Its almost like after about 2-3 minutes the device is going to “sleep” and the only way to wake it up is to “send map to morph” in the software. For example, nothing changes and I have the morph “press” for example controlling a midi cc and modulating a parameter in bitwig. Then, without changing anything at all…It just doesn’t control that parameter anymore. Then I just press “send map to morph” on the app and all of a sudden its working again.

Is my unit defective or is this a known issue. I am plugged in at all times via the included USB cable so I am not in any bluetooth mode or relying on battery (which is 100% since its always plugged in btw). I am on v0.19.32.

Hey Javon. The Bitwig script and SenselApp seem to not play nicely together. It’s a bit mysterious, and we hope to uncover a fix. We recommend making your changes in the App, closing it, then using the Morph in Bitwig. Sorry for the inconvenience.

1 Like

Ah, I see and thanks for your fast reply. So if I understand correctly @Matt_from_Sensel you’re saying is that the issue might be tied to the fact that I have been keeping the Sensel app open while using it in bitwig. Because that has been how i’ve been using it (just because i’m doing a lot of testing, whereas normally I don’t expect that I would keep the Sensel app open all the time). So hopefully it’ll give me a little more reliable performance if I keep the sensel app closed during Bitwig use.

Just wanted to update that unfortunately closing the Sensel app while in Bitwig doesn’t improve the matter at all for me @Matt_from_Sensel

The Morph still randomly loses connect with Bitwig even when the Sensel app is closed during use. That means I have to reopen the app anyway just to resend the map to “refresh” it. So technically, its easier just to leave the app open since I pretty much have to send the map before any use due to the inconsistent connection issues. Kind of annoying to deal with so hoping there is a solution to this issue in the not too distant future since connection is core to the functionality/practicality of a device like this.

Hmm, we’ve never experienced this, so it sounds like something else is going on. A few questions:

  1. When it needs “refreshing”, is it unresponsive, or is it just sending the wrong MIDI data?
  2. What OS? Can you test with MIDI Monitor?
  3. Does it happen with other programs, or just Bitwig?

This could also be a hub/cable issue, but opening the SenselApp wouldn’t solve that.

Hi @Matt_from_Sensel

Yes, its entirely unresponsive in bitwig once it goes. Then I resend the map and it starts working 100% of the time. I can tell that the sensel morph is receiving my input (the LED still lights and in the app itself when I go to the visualizer it is still receiving input with no issue). I numbered my response to go with your number system in your reply for clarity.

  1. However its like the connection to Bitwig is disrupted and it just stops communicating MIDI. There is no real pattern to it. Sometimes, it works for 10-15 minutes, other times, 1-2 minutes, and sometimes 20-30 seconds. I’ve tried some controlled tests where I just connect it and do nothing in the DAW to see if it works and still it just randomly stops with no real pattern to it. I’ve tried with the Sensel app both opened and closed and neither of these seem to matter.

  2. I am using Windows 10 Pro 64 bit. If you have a specific test that could help you diagnose/troubleshoot i’d be happy to try anything, as all I want is a consistent connection like all my other MIDI devices and I would be VERY happy, so i’m committed to working at this while i’m still within my 30 day return period to see if I can get it figured out within the next 2-3 weeks. Do you have a specific “midi monitor” software (including link) I could try that could help diagnose?

  3. I have Ableton but only really use Bitwig so I haven’t even tried or set it up with any other software since I don’t plan to use Ableton for the foreseeable future.

Yeah, I dismissed it being the cable since I can get a response in the sensel app “visualizer” even when the communication to bitwig stops (so I don’t think its the cable, or connection port, or Morph hardware). I just confirmed to be sure.

Also, here are the bitwig midi controller settings (they are just the default settings as I didn’t change this) but I wanted to make sure that this 2 way communication setup is the ideal one.

image

Other information that might be useful. I am using the sensel morph in the “no overlay mode” and for the overlay settings I have the “note off” as I want to send midi cc and aftertouch without sending any note information. Here are my settings:

I’d recommend downloading Microsoft MIDIBerry. According to this helpful article, you may also need loop midi to set up a virtual MIDI port.

Sent the rest of your issue to our team internally and will get back to you as soon as I hear back.

It looks like “midiberry” is for bluetooth connections, but in my case I can completely connected via a USB cable. So my device is connected by the cable the whole time. Also, I can see that device isn’t losing connection to bitwig, its just not communicating midi.

Thanks for the details. Are you only using the Morph in No Overlay mode? Do you use any other overlays? I doesn’t look like it from the SenselApp, but thought I’d ask. This is a bit out of the normal expected use for the bitwig script, as it does listen for the notifications that an overlay is on it - it may be that no overlay trips things up. It might be productive to trt something more generic if you are only using the Morph like this. Can you try loading the Roger Linn Design/Linnstrument script and using the Morph as the in and out?
Can you share the “no overlay” mapping with me so I can try here? Go to the top right and “export” the senselmap.

1 Like

Hi @Matt_from_Sensel @peter_sensel

I have an INTERESTING update for you and the internal team, I just went back and tried Bitwig 3.2.8 (the last official Bitwig release) for the first time and it seems like the connection is stable there and I haven’t had it drop yet. I’ve been testing for about an hour or so (i’ve never had the Morph stay connected and sending MIDI continuously this long in my tests in the 3.3 Beta 3.

So I might just be a few days/weeks early on a more widespread problem coming for Sensel Morph users in Bitwig 3.3 when the official update is released very soon. In the new Bitwig 3.3, it seems that these connection drops happen consistently (every few minutes/seconds randomly prompting a resend of the map to get it working again as described above). However, in Bitwig 3.2.8 I haven’t experienced these issues after almost an hour of having it connected. So could you relay to your team that they may want to try the Bitwig 3.3 Beta (beta 3 is the most recent one), as that may give them a head start on figuring out what changed and what might be causing the issue, and also you may be able to reproduce the issue that may not have been there prior.

I’ll report back if I get the issue in 3.2.8 as I do some random tests in the coming hours days, but so far it seems it’s a v3.3 issue.

Hi @peter_sensel (thanks for the recommendations)

In response to your last reply, I do have 2 overlays (the innovator and piano overlays), I just have been doing all my tests with no overlay on. So i’ll try it with the innovator overlay to see if that helps matters and report back. If that doesn’t resolve the issue, i’ll also try the Roger Linn Design/Linnstrument script with the morph as an in and out to see if that resolves the matter.

I’ll be doing all my testing on the Bitwig 3.3 Beta 3 (because 3.3 is great) and ultimately we all won’t be able to avoid these issues once the official 3.3 is released any day now and users start upgrading. Its interesting that 3.2.8 doesn’t seem to have these same issues with the “no overlay” mode.

Thanks to you and @Matt_from_Sensel for your responsiveness as I am committed to doing all the tests I can to help resolve to get the Morph working in 3.3 (or at least understand what might be the cause of those issues that do not appear to be happen under the exact same condition in “no overlay” mode in 3.2.8). I’ll likely have updates for you within the next few hours.

@Matt_from_Sensel @peter_sensel

Exciting News! It seems that what peter mentioned about the overlay being necessary to avoid issues with the Bitwig script was in fact the source of the issue in Bitwig v3.3 (Beta 3). I put on the innovator overlay and the connection issues are no longer a problem. Its been working consistently for about 2 hours now with me testing randomly every few minutes (and before I never was able to stay connected anywhere close to more than 5-10 minutes when I didn’t have any overlay on the Morph). So it looks like there is an issue using the morph without an overlay in v3.3 of Bitwig that wasn’t present with v3.2.8 since it worked as expected with no overlay in 3.2.8. So the script in 3.3 is checking for an overlay notification like Peter mentioned and when it checks and there isn’t one in v3.3 it must be causing an error which is only resolved by manually resending the map from the sensel app. So previously, it probably always worked until whenever the bitwig script decided to look for an overlay notification and then turned off after the error.

With an overlay on, its now working perfect so thanks to you both for your quick replies and helping to resolve. I’m pretty excited to have the Morph working without needing to keep “refreshing” it every few seconds/minutes, so i’m glad we kept troubleshooting as I was losing hope. I definitely can attest to quality product/customer support from the Sensel team working through this issue, so thank you both.

1 Like

Great to hear. Thanks for the updated details - I’ll have to investigate the Bitwig beta thing. Very weird that it would be have so different. Glad you are up and running, sorry for the hassle!

@peter_sensel

Quick update. I left everything on overnight so after about 10 hours since my last test the Morph is still sending midi data to bitwig v3.3 without needing the map to be resent in the software which is great news. There may still something random in the script for Bitwig that is causing some minor connectivity issues in v3.3 that is worth checking out (especially in the “no overlay” mode), but things are going well with the innovator overlay on it.

If your trying to reproduce my test setup from the past few days on your side, I basically am just using a “midi” modulator on a bitwig device with simple Sensel app settings to send channel aftertouch. You can see my settings in both bitwig and the sensel settings in the images below. For my simple tests while I do other things, I just press the morph pressure every once in a while to see if the “midi” modulator on the device shows any feedback to see if it stays connected over long periods of time. I want to see how long it would stay connected continuously without needing a refresh in the sensel app.

image

Also, here are my studio I/O settings in case that matters. All I did was turn off the notifications as I find them to be a nuisance. You can see those settings below as well.

Twitter RSS Facebook