Teething problems updating Map

Hi There,

Just received my Morph and tried (but so far failed) to configure the Innovator’s Overlay. I’m using a MBP 16" and Logic 10.5 and the Piano Overlay worked out of the box. But using the SenselApp, I seem to be hitting some bugs or (more likely) newbe problems…

I’ve mapped out a simple key to test and selected Send Map to Morph, which did what I expected, but when I edited the Map (changed the MIDI note of the button from an E to an F, the Send to Morph button goes black, but selecting it does nothing. I couldn’t update the Morph. I’ve restarted the app and Morph, but its stuck with the first demo. Any ideas what I’m doing wrong?

This does sound strange.
Can you try moving your ~/Library/Application Support/unity.Sensel.SenselApp/ folder to your desktop and starting the SenselApp again?
You may also need to try a different USB cable or skip the hub and plug directly into the laptop (if that’s relevant). Once you click “Send Map to Morph” it should change to " Sending Map…" then “Send Complete”.

Hi Peter,

Thanks for your reply.

I did as you suggested and it worked once (for the first Send Map to Morph) but when I edited the button and tried again it didn’t update. I also tried a different USB cable and that didn’t work either.

can you send me the senselmap file for the Innovator’s Overlay that is in ~/Library/Application Support/unity.Sensel.SenselApp/Innovators
I’d like to see if I can reproduce.
Similarly, here’s a senselmap that I just made and easily flashed and edited to my Morph. Curious if you can import it and do the same.
randall-test.senselmap (6.6 KB)

I tried your test app and it initially crashed the app - but then when I restarted it worked and I could update it.

Let me know if you want the crash log.

Cheers,
Stephen

Demo.senselmap (6.52 KB)

Hi Peter,

The problem has returned, so I can’t program the Innovators Morph. Any ideas what I can do now?

Stephen

More info:

My #1 requirement with Morph is to add pitch bend to my MIDI workflow (I have a Nord Piano 3 which doesn’t have a pitch wheel). I thought I could easily set that up but with my teething problems, I have not been able to achieve this. (I can get small pitch bends on the Piano overlay, but not independent pitch wheel movements that I was hoping to set up via the Innovator’s overlay).

My #2 requirement is more ambitious - to use the Innovator’s Overlay to create at least 2 but up to 6 channels of MIDI guitar “digital strings” - essentially 6 areas tuned say EADGBE, each on a different MIDI channel so I can pitch bend any without impacting the other “string” areas. Technically, I can’t see why that won’t work but that’s only a stepping stone to a much more ambitious goal; I’m hoping I can build a similar interface with “frets” (so each "string has discretions notes) so I can slide up each string - but I’m not sure the Morph regions allow slides across notes (the Piano doesn’t) - so that might involve a deeper programming chops…

HOWEVER, I’m unable to get started. As posted, for some unknown reason, as soon as I flash a new Morph, I then cannot flash it again, and I’m stuck with the problem I originally posted.

Fingers crossed here. Any help appreciated.

Cheers,
Stephen

This is really strange - can you attach the full crash log?

I’ll email it to you as the forum isn’t allowing the file format to be attached.

Stephen Randall
Cell: +1 917 480 9995

(Attachment Sensel Crash Log.rtf is missing)

Hey @stephenrandall. It looks like you may have a couple devices on a USB hub. Some hubs do not work well with the Morph, especially when multiple devices are plugged in. If this is the case, we would recommend trying to plug it in directly. Let us know if that helps.

Thanks,
Matt

Hi Matt,

Yes, I did try plugging in the Sensel directly to my MBP but that has not stopped the (presumed) bug where I can’t update the Morph - it might have stopped the crash (which could have been an unrelated problem) - FWIW - I always seem to be the user who finds the edge cases :frowning:

Cheers,
Stephen

Twitter RSS Facebook