[Solved] MPE velocity is unnatural!

#1

I feel awkward everytime I play drums with innovator’s overlay.
Recently I’ve found a reason.

Hitting one “MPE/MIDI XYZ Pad” while pressing on another area can cause unnatural velocity (like value “1”).
It was not happening on “MIDI Note Buttons”.
Turning off “X”,“Y” and “Press” and unchecking other options didn’t have any effect.

Can you fix that?

I use windows10 64bit, up-to-date sensel app and firmware.

#2

Hello, thank you for reporting the issue. We just released a build update today that should fix this issue. The current version is 0.19.172. Please let us know if you have any further issues.

#3

Thank you for your super quick fix !

This issue is solved.

I’m looking forward to the further sensitivity improvement of overlays other than Drum Pad Overlay, but anyway,

thank you sooo much !