[SOLVED] Windows 8.1 installation and usage woes

Hi All, just received the Morph and have some issues. Hopefully a simple fix is possible as upgrading OS isn’t currently possible.

Full story of the 3 hour experience so far:

When plugging in the device for the first time and running Ableton, all went seemingly as expected, bar the fact that one of the keys on the Music Production tends double trigger always. Since I wasn’t able to fix that, I figured I need to update the Morph and get the Sensel APP working on my old Windows 8.1 OS - so I exited Ableton and focused on the firmware update.

I ran the Sensel APP and was unable to connect and update the Morph, so I installed the Windows 7/8 driver from the start guide page. This didn’t have any result after multiple reboots, changing usb cables and ports (hub and direct). So I dove into Device Manager.

The only entry I could find for Sensel was in the Ports section. So I checked the Morph with an Ipad over Bluetooth - there the double triggering key didn’t seem to act up (didn’t investigate fully) and it seemed to work really well. So I checked the morph on a W10 machine (no creator update) and the Sensel App worked and I was able to flash new bios onto the device. I didn’t test the midi retriggering issue overlay yet. Bluetooth expectectedly doesn’t work without the update…back to the W8.1 machine…

I loaded up Ableton to check if maybe the retriggering key was fixed, since the LED displays started to act a bit different after the firmware upgrade - no Sensel Morph found! I thought maybe the device got set into some special MPE mode, so I checked Bitwig - also not found. The MIDI device for Morph was no longer available anywhere.

After about 2 hours I’ve traced the issue on my system to the fact that installing the driver from the Get Started page (https://sensel.com/pages/support) might have an issue with 8.1 or my particular, messy dev workstation.

I still can’t get the APP to see the device after multiple reinstalls and trying different COM ports with or without the Windows 7/8 driver and the Midi retriggering of one key on the Music Production overlay persists even after trying to realign it on the Morph different ways - but that’s another topic.

I checked Device Manager and I see that the Sensel Devport has a warning - and that is the missing driver from the Get Started page I assume - however installing the driver for that device is impossible as windows says no driver was found in the files. Previously I achieved installation by simple right clicking and selecting install on the “sensel_morph.inf” file. I see a lot more Sensel device entries in the manager without installing the distributed driver.

So at this point I have it working on the system with the retriggering issue (might be unrelated overlay defect) and no Sensel APP or windows driver.

Guess I just needed to write all that out to understand that maybe I wasn’t installing the driver correctly.

So the right way is to plug the device in, let windows auto install everything - then go to device manager and add the driver for the Sensel Devport, not by Update Driver->Browse My Computer for Driver and pointing to the folder with the driver, but by “Let me pick from a list of devices” and THEN click the option for HAVE DISK. ffs. Yes it is an old OS but that is rediculous.

all good now I think, APP works and I can focus on the retriggering issue.

Twitter RSS Facebook