Trouble setting up with MacOS 10.12.5


#1

Just plugging in my Morph for the first time and having trouble updating the firmware. It’s tried twice and failed both times.

  • I don’t see the WiFi icon in the lower right of SenselApp - only USB and question mark.
  • SenselApp v0.9.12
  • current firmware v0.7.79 (though at various times plugging and unplugging, i’ve seen some pretty crazy firmware version numbers here…)
  • the Visualizer doesn’t start up - just remains blank. I’ve restarted the SenselApp a few times, and did see the Visualizer once, but only once.
  • Sensel Driver is installed and running, I was able to use the Keyboard overlay/mode, but have tried the ‘no overlay’ mode and get no response from my mouse.

that’s all I can think to report at the moment. Would love to start using it!


#2

Hello, thank you for reaching out and sorry to hear you are having issues.

  1. If updating and the visualizer are failing, it is likely a serial communication issue (which is used for both). We have experienced issues with serial communication on Windows 7 and when the device is run from a virtual machine. If possible, try updating on a Windows 10 computer or a Mac. We will continue to improve the compatibility of the Morph and our App.
  2. Based on your title, I see you are running on a Mac. In that case, try quitting the App, unplugging all USB devices including the Morph, just plug in the Morph, open the App, and try updating. If it continues to fail, please let us know the computer you are using, and how the Morph is connected to the Mac (are you connecting over standard USB or is it a dongle to USB-C) so we can reproduce the issue.
  3. The WiFi symbol has been removed from the latest version of the Sensel App (0.9). Instead, if no internet is present, a warning will pop up when you click the Update Morph Firmware button. We are in the process of updating the docs for the next release.
  4. Version 0.7.79 is the version loaded on the Morph out of the factory, you may also see Version 0.6.22, which is the backup version used for updating, and a fallback if updating fails.
  5. The Sensel Driver is only necessary for the Art Overlay and the No Overlay Painting Mode. No Overlay mode can only be enabled for firmware version 0.9 and later.

I hope these responses help and let us know if you continue to experience issues. Thank you for your support!


#3

Wow - what a difference when it’s the only USB device connected! I’m on a late 2016 MacBook Pro, with all USB-C ports. I use two different dongles: an Apple USB-C -> HDMI/USB/USB-C and a Hyperdrive dongle. I had a fancy keyboard plugged in to the Hyperdrive alongside the Morph. Firmware updated fine and the SenselApp is far more responsive than it was before.

All is well, thank you for your quick reply and suggestions!

Cheers!