Octave Shift should reset when swapping overlay

If I shift up octave using a MIDI Morph Modifier on my Innovator’s overlay, and then remove my overlay and play in “No Overlay” mode (configured to send a single MIDI note : C3) , the octave shift still apply. (playing a C4 instead of C3)
This is a real issue, as in “No Overlay” mode, there is no way to setup more than one Area, so I can’t shift down to the key it is supposed to play.

FR : when swapping overlays, octave shift should be reset.
(or it could be a global option)

another FR : a MIDI Morph Modifier “Octave reset” would be really appreciated :slight_smile:
As there is no way to know how many times you pressed Octave Down or Up, it’s easy to get lost, no way to be sure to play the desired octave :-s

Thanks for the heads up here @matcham. We were able to replicate the problem and added it to our queue of bugs to address.

And it should go lower than C0. It would be nice to use this for articulation switching sometimes, but impossible with a C0 limit.

Twitter RSS Facebook