[Solved]: (Mac) Morph not showing as control surface in Ableton

I just downloaded the Ableton script and tried to set it up according to the instructional video, but the Morph doesn’t show up in on the “control surface” section.

Thanks in advance!

I’m sure that the Sensel techs will jump in.

I had the same problem. They said that the current Albeton Morph scripts use new scripting features in Live and require Live 10.0.4 or higher to work correctly. I upgraded to 10.0.6 and the installation worked and Live was able to see the Morph Control Surface.

Hope this helps.

Same problem here- all Morph firmware and software current. OSX10.12.6
Live 10.0.6


I’m not sure why this didn’t work for you but I just confirmed this is all ok:
Go to the Ableton application, right click, and show package contents. Navigate to Contents/App-Resources/MIDI Remote Scripts and delete the Sensel folder. Go to github and download
navigate to
/Users/nbor/Downloads/sensel-controller-scripts-1.1/Ableton/Installer/Mac/Packages Project/Sensel_Morph/build/Sensel_Morph_LiveScripts.pkg
and run the installer there.

We will soon be updating the scripts on the store.

Thanks Peter.

Finally getting back to this issue today. First thing I find is that with both Ableton Live 10 Standard and Ableton Live 10 Suite installed on my system, the Sensel Folder was installed in the STandard remote scripts folder and not in the suite folder. So I will address that first. Should solve my issue, no?

Ah, so do you have 2 versions of Live on your system? Yes, if you move (or copy) the scripts to suite, you should be good.

Tried that. Still not working. In Ableton prefs, the Sensel is available as an in/out source, but not as a Control surface.

And in the Sensel Live Remote Script Demo, the Ableton overlay does not control transport OR clips.

What am I not getting?

Still Live 10.0.6? Or 10.1?

10.1- auto updated. Realizing pad in map are controlling notes not clips. whoops. But still no transport functions.

Well, if it’s not showing up in the Live Control Surface Scripts list, then it won’t do what it is supposed to.
You will want to get the latest scripts (you should have gotten an email that they are updated). Installer is in our github repo: https://github.com/sensel/sensel-controller-scripts

Yup downloaded that Sensel-controller-scripts-1.1 That’s what I’m working from. I have run the installer in that package to no avail. The midi controller scripts in the Ableton package show a current modifcation date, so I’m assuming they have been updated. I can’t figure out how to install the current overlay versions either… can’t drag and drop in the Sensel App, and the overlays that show up when I hit the Add Overlays tab in the app do not include the Ableton ones.

Are you on
Mac or windows?

I am on Mac Sierra 10.12.6

I’m reading the readme in the installer folder -

  • place a current copy of “Sensel_Morph” controller scripts at the destination location on your system (/Users/Shared/Sensel_Morph)
  • place a current copy of the “Project” folder (has a Live project) at the destination location on your system (/Users/Shared/Project)
  • place a current copy of the “Overlays” folder (has a Live project) at the destination location on your system (/Users/Shared/Overlays)

None of the referenced folders are in users/shared, BTW

That’s is a reference for building the installers - not for general use :slightly_smiling_face:
I just sent you a PM.

OK Finally got it by following the readme instructions. All the folders were in my user folder, not shared, so that was a bit confusing. Haven’t tested everything but at least the Sensel shows up as a Co
ntroiller surface option in Live. Will load the new Map and try it out. I think maybe a little clearer instructions for how this install should be accomplished are in order?

For the record - we did a google hangout so I could see what was going on, and we were able to load the Maps so the script runs with Ableton Live 10.1

I’m on Windows and planning to upgrade to Live 10.1 very soon. Are there any gotchas that I should be aware of? I have the latest Live script installers via the recent email.


The Scripts are compatible with 10.06 and 10.1. Issues with the above were sorted out with making sure the correct maps were installed on the Morph. The user also had 2 versions of live installed. Turns out the installer was putting the scripts in the version he wasn’t using, so it didn’t show up in the version he did use!


  • Tried to just say Thanks! - but the forum software requires at least 20 char. I think I made it :wink: