[Solved] Overdub Set Control in Bitwig Studio 3.1.1

Isn’t the record button on the Music Production Overlay (MPO) supposed to toggle overdub in Bitwig Studio, when using the correct map?
Most other buttons work as expected, including “shift-record”. Yet the “record” button does nothing on its own.
This is with BWS 3.1.1 on macOS 10.14.6 (Mojave), which includes the 1.1 controller script in the app itself. I also tried with the script on Github. And I installed the controller scripts from the installer, switching between scripts in the Bitwig preferences.

Toggling the overdub button works well in Ableton Live 10 Lite using the same overlay (and the Ableton map). In fact, the Ableton map works fine in Bitwig apart from this function.

Checking the JavaScript in the controller script (MorphMPE.control.js), I notice that, in keysPage.update_mode, this line is commented out:

transport._record.set_control(button[6]);

Same with transport._record.set_control(button[6]); in mainPage.update_mode.

I tried switching the commented lines (or having both active) to no avail.

That button 6 line (transport._overdub.set_control(button[6]);) is active in keysPage.enter_mode.

It sounds like shift-record is enabled by this (in mainPage.update_mode, keysPage.update_mode and in drumPage.update_mode):

session._record_clip.set_control(button[6]);

I’m taking for granted that other people have used that overdub button in Bitwig Studio (or, at least, in Bitwig 8-Track, which ships with the Morph; what’s strange is that controller scripts are quite different as 8-Track is based on BWS 1.5…).

So, erm… what gives? Is this really a problem just on my system?

Thanks!

Oooooops!
Just noticed that this button does work as planned. It’s just that… there’s nothing noticeable in the Bitwig UI to say that overdub is active.
Ah, well… Now I know. Hopefully, it can help somebody else.

Twitter RSS Facebook