Startup bug: no overlay / innovator's overlay

Hello!

I am using 4 morphs as part of a semi-publicly installed multiplayer musical instrument. I have designed some fancy custom hardware to seal my morphs into anti-vandalism enclosures. The problem I’m having is that the Morphs won’t boot up properly without an overlay. I was relying on the feature that loads the Innovator’s Overlay template when no overlay is present on the device. Unfortunately, in newer firmware versions for the Morph, it seems to load the overlay correctly, but won’t begin transmitting data until either A) the innovators overlay is placed on the unit or B) the Sensel app is opened on the host computer. I have made a short video to demonstrate the bug: https://drive.google.com/file/d/1CdlQ8ukjTq4K5IUiqxyUVHsphytdJYZh/view

I am eager to solve this problem so I can complete my project.

Please help!

Thanks,
Moldover

You’re not the only one. I’ve noticed this as well!

1 Like

Hmmm… I haven’t used my Morph that much. And I’m still waiting for them to fix a single bug from 7 months ago… Anyway, here are a few suggestions/questions from my limited experience:

  1. “It’s loaded the innovators overlay” - without the overlay in place? What indications do you have it’s loading the Innovator and not the “No Overlay”? Have you tried making sure that “No Overlay” has the same layout as what you have for “Innovator Overlay”?

  2. Have you tried turning the morph off and on again to see if that makes a difference? Is the battery fully charged?

  3. Since plopping the Innovator down works, and you’re constructing an installation, have you considered adding the 4x circular identification magnets to each of your overlays to tell the Morphs to treat your interfaces as the Innovator? See page1 & page2

  4. If it is a firmware update issue, maybe you can get Sensel to help you roll back the firmware to an older version.

1 Like

Hey Galen,

Thanks for the excellent suggestions.

I know it’s loading the Innovator’s Overlay because the white LEDs on the unit respond to touches, and visualize the customized layout I made.

In the Sensel App, in the “No Overlay” section, it doesn’t seem that a custom layout can be created or assigned here. It seems the user is offered one single touch-zone spanning the entire device, and you can select “Load Innovator’s Overlay Map and Layout”, or have that one zone be something like a mouse/touchpad.

I have considered installing magnets, but because I have gone to great lengths to “harden” these Morphs inside of custom enclosures, it would take a very long time to modify them to accept magnets. The units used to perform as one would expect (sending appropriate messages after startup without connection to the app or having an overlay placed/removed) so I believe this is a bug that Sensel will wish to fix to satisfy users.

I like your suggestion to roll back the firmware. I am hoping to get a response from someone in support or development. I’ll report back here if I am successful.

Thanks again for the ideas!

Best,
Moldover

1 Like

Whoops, I didn’t read your message correctly the first time through. So what happens when you select the “Load Innovator’s Overlay Map”? or is that what you were already doing?

So while you don’t want to insert magnets on the front, could you feasibly slap the ID magnets on the backside of your Morphs? I haven’t tried so I don’t know if it would work.

Hopefully @Matt_from_Sensel or @alex will be able to address your issue.

I am already doing as you suggest and selecting “Load Innovator’s Overlay and Map”. The device is receiving this instruction (it is reflected in the white LED feedback), but it won’t transmit data until an overlay is applied to the hardware.

You can apply overlays to the back of the device as you suggest and they are recognized.

I have created some fancy custom hardware (CnC machined aluminum, steel, polycarbonate, etc. etc.) to seal my morphs into anti-vandalism enclosures, so adding magnets to the front or the back would involve LOTS of time, and would add an unnecessary complexity to the design for future maintenance (which someone else will be responsible for).

I know this is a firmware bug. I have a Morph running an older firmware and it doesn’t have this problem. It is absurd to me that modifying my hardware would be the best solution to a firmware bug. I hope someone from Sensel responds.

Best,
Moldover

Whoops - I did alter my message but probably not before you received it.

Okay, so they’re sealed in tight without any space… That’s unfortunate but it is what it is :frowning:

You should probably email/call them directly to try to get things expedited. If they don’t help then worse comes to worst, maybe you can find someone who has a copy of the software & firmware that hasn’t been updated. Do you know what version/date the firmware started to not work properly?

And yes, I agree you shouldn’t have to alter hardware to fix a firmware bug… however given I’m still waiting for a bug to be fixed from back in May, you may have to find a way around Sensel’s support. Here’s hoping it won’t be the same for your bug…

When I finally give up waiting on them I’ll have to implement my own circuitry/hardware workaround - something I’m not looking forward to doing :sleepy:

I have been assured that a firmware fix will become available soon. I’m keeping my finger’s crossed…

( ! )

1 Like

Yeah, I was pretty much told that too🤞

I was told that the bugfix I was waiting for would be released in “the next update”. The “next update” happened and it had nothing to do with my bug…

Twitter RSS Facebook